Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

1 of 2 Instances stopped backing up - "Invalid handle to path" Error

  • 105 Views
  • Last Post 02 July 2021
JohnnySharper posted this 27 June 2021

Hello all, I have 2 minecraft instances on my server and one quit backing up a few days ago, nothing changed, no updates were ran, just out of the blue came up with this error.

Unable to add /home/amp/.ampdata/instances/DireWolf1165/Minecraft/world/region/r.0.1.mca to archive: Invalid handle to path "/home/amp/.ampdata/instances/DireWolf1165/Minecraft/world/region/r.0.1.mca" - aborting.

The other instance is still backing up fine. Here is what i have tried,

  • I checked the drive space, deleted some old backups just to be sure.
  • Updated amp to 2.1.2.0, restarted the AMP server
  • Installed all the latest Linux updates, restarted the Linux server.
  • Reboot everything again. No dice.

If you try to create a backup, it runs to the last 25 secs then stalls for a minute, then a message comes up and says "You've lost connections to AMP backend please wait etc." and when the page comes back the backup error is up in a "unable to complete task" window

Here is my server info,

  • OS Linux
  • Platform Ubuntu 20.04.2 LTS
  • System Type x86_64
  • Virtualization None
  • Module ADSModule
  • Loaded Plugins FileManagerPlugin, EmailSenderPlugin, WebRequestPlugin, LocalFileBackupPlugin, CommonCorePlugin
  • Application Name AMP
  • Application Version 2.1.2.0
  • Release Stream Release
  • Build Date 24/06/2021 15:20

Order By: Standard | Newest | Votes
Mike posted this 30 June 2021

You've probably exhausted your open file handle limit, you should increase it.

JohnnySharper posted this 02 July 2021

You've probably exhausted your open file handle limit, you should increase it.

Thanks for the suggestion, I used the ulimit fuction to expand the handle limit by a few thousand and reboot the system and its still errors. I also reset the permissions for the AMP user just in case something changed somehow, still no dice. I ended up fixing it by removing the file in question and putting it back using the SFTP connection and then rebooted everything and now its backing up as normal. Must have just been a weird glitch.

Close