Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

ADS says almost all instances are stopped, besides for one.

  • Last Post 06 August 2020
  • Topic Is Solved
kprose posted this 04 August 2020

OS Name/Version:

 Windows Server 2019 Datacenter (Desktop Experience) Build 1809 

Product Name/Version:

 AMP v2.0.3 - McMyAdmin

Problem Description:

ADS shows almost all instances to be stopped, besides for one.  If I "Start" one of the instances it says it is running after but I know it is already running by task manager. But if I try to "Start" another the one I just started "Stops"  and one I just attempted to start is "Started". This is after my other discussion "Unable to start AMP instances from ADS after management." and I recreated all my instances to be fully under the control of ADS. What would have changed to cause this? I do see some errors in the logs for ADS. I linked a Pastebin link below if the latest log.

Steps to reproduce:

1. It just appeared one day

Actions taken to resolve so far:

I have tried different browsers (Firefox, Safari, Chrome, New Edge) and different modes in browsers (Normal and Private mode). Restarted the ADS instance, and the physical server.

Order By: Standard | Newest | Votes
Mike posted this 04 August 2020

Check the logs for the actual instances.

kprose posted this 05 August 2020

I pulled the latest log from McMyAdmin01 (BungeeCord (Travertine variant), Port 1710). It seems to be having errors with port binding which is weird because it still happens after a full system reboot. I ran Netstat with PIDs included and it said was listening on and the foreign address is and the PID matches what is in task manager with an AMP Service Handler process. Would it be because I made a rule in Windows Firewall? I will fix the issue with the jar owner once I get this fixed.

Log of instance

Netstat output (Filtered to relevant ports)

Mike posted this 06 August 2020

Check what port AMP itself is bound to.

kprose posted this 06 August 2020

The AMP instances are bound to the ports they are supposed to be bound to (McMyAdmin01: 1710, McMyAdmin02: 1711, McMyAdmin03: 1712, McMyAdmin04: 1713, McMyAdmin05: 1714, McMyAdmin06: 1715, McMyAdmin07: 1716, McMyAdmin08: 1717, McMyAdmin09: 1718, McMyAdmin10: 1719, ADS01: 1735)

kprose posted this 06 August 2020

I just figured it out, I disabled Start on Boot from inside ADS and restarted, I opened task manager and they are running which they are not supposed to be. The issue is that AMP did not remove the services from Windows so it will try to start them independently. For anyone with this issue in the future use the sc delete "service name" command unless advised otherwise.