Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

ADS won't start after update

  • Last Post 03 February 2021
  • Topic Is Solved
schuwima posted this 29 January 2021

OS Name/Version: Windows 10 20H2 under KVM virtualization

Product Name/Version: AMP

Problem Description: ADS won't start after update

Steps to reproduce:

  1. Update to
  2. Restart System

Actions taken to resolve so far:

  • Re-Install Service using AMP Instance manager
  • Check ADS logs (There are no new ones, seems that logger died)
  • Cry
  • Check Windows Event Viewer
  • Reinstall AMP using the repair option
  • Uninstall Service and start AMP.exe automatically

In Windows Event Viewer I can see the following lines (second entry is german, sorry):

Application: AMP.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeLoadException
   at GSMyAdmin.Core.SetupDatastore(GSMyAdmin.Logger)
   at GSMyAdmin.Core.Run()
   at GSMyAdmin.Program.Main()


Name der fehlerhaften Anwendung: AMP.exe, Version:, Zeitstempel: 0x60119cf3
Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 10.0.19041.662, Zeitstempel: 0xec58f015
Ausnahmecode: 0xe0434352
Fehleroffset: 0x000000000002d759
ID des fehlerhaften Prozesses: 0x106c
Startzeit der fehlerhaften Anwendung: 0x01d6f6954e3848dc
Pfad der fehlerhaften Anwendung: E:\AMPDatastore\Instances\Unraid-WIN10\AMP.exe
Pfad des fehlerhaften Moduls: C:\WINDOWS\System32\KERNELBASE.dll
Berichtskennung: 5d551e0c-010d-4f67-9962-c8419ab1a400
Vollständiger Name des fehlerhaften Pakets: 
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

While starting ADS using AMP.exe I can see the following:

[01:12:02] [Program Info]         : Starting AMP version (Ganymede), built 27/01/2021 17:03
[01:12:02] [Program Info]         : Stream: Mainline (Release) - built by CUBECODERS/buildbot on CCL-DEV

Unhandled Exception: System.TypeLoadException: Method 'Get' in type 'GSMyAdmin.Providers.SQLiteDataProvider' from assembly 'AMP, Version=, Culture=neutral, PublicKeyToken=null' does not have an implementation.
   at GSMyAdmin.Core.SetupDatastore(Logger log)
   at GSMyAdmin.Core.Run()
   at GSMyAdmin.Program.Main()

Order By: Standard | Newest | Votes
schuwima posted this 30 January 2021

I figured out I can downgrade using the in my instances folder. ADS and my instances run fine now.

Nonetheless it is quite strange, that the update to Ganymede is giving me these issues.

Mike posted this 30 January 2021

Don't downgrade, it can damage your installation. Upgrade again and if it persists, run AMPs installer in repair mode and reboot.

schuwima posted this 31 January 2021

Upgrade again and if it persists, run AMPs installer in repair mode and reboot.

Thats what I did. And it did not work.

I will try to migrate my current instances temporarily to a new AMP installation and try to upgrade my current one

Mike posted this 31 January 2021

It's definitely an assembly caching issue. Make sure AMP is fully shut down before you repair the installation.

jrsrjrsr posted this 31 January 2021

I have the same problem with same Unhandled Exception and can confirm that repair mode does not correct the problem.

Before running repair, I shut everything fully down via appinstmgr --StopAllInstances command line, confirmed that nothing was running via appinstmgr --ShowInstancesList, and also looked at Windows Services app to make sure the service was not running.

  • Liked by
  • schuwima
andrew d posted this 02 February 2021

I also have this issue after upgrading to

Have fully shutdown AMP and repaired installation, but I have identical problem described by schuwima

  • Liked by
  • schuwima
Mike posted this 02 February 2021


ampinstmgr --nocache upgradeall

  • Liked by
  • schuwima
schuwima posted this 03 February 2021

Well, that worked. I was able to update my instances without any problem now

andrew d posted this 03 February 2021

Thanks Mike, worked for me as well