Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

AMP Instances won't bind to port on Windows Server 2016 [Solved]

  • Last Post 13 August 2017
  • Topic Is Solved
DreadPirate posted this 12 August 2017


OS: Windows Server 2016 [Version 10.0.14393] Product: AMP Application Module: Minecraft

Problem Description I've installed a fresh installation using the latest version of AMP on a new Windows Server 2016 install.

I am unable to get the instance to bind to any port on any IP. I didn't have this problem on my Windows Server 2012 R2 install, so I'm guessing it has to do with possible security feature "improvements" in 2016.

I did have to do some extra work to get my Apache server running, however that process did not help with the AMP Instance.

Steps to Reproduce Create a new Instance within AMP on a Server Running Windows Server 2016

Actions Taken For reference, I had to run the following commands to allow my Apache service user to bind to port 80 (non-admin user): netsh http add urlacl url=http://+:80/ user=%COMPUTERNAME%\MyLimitedApacheServiceUsername

I attempted to run the following command to facilitate the same solution, however it has not resolved the issue:

netsh http add urlacl url=http://+:50080/ user="NT Authority\Network Service"

AMP Log Infomation The error I am receiving in the log is:

[12:26:38] [GSMyAdmin:System Info] : Licence Present: AMP Professional Edition (Licenced to DreadPirate) [12:26:38] [GSMyAdmin:System Error] : Unable to start webserver. Port may already be in use or IP binding is invalid.

Additional Information I have validated that the Port is not in use. UAC is Enabled

Any help would be appreciated, thank you.

Order By: Standard | Newest | Votes
Mike posted this 12 August 2017

What's the last 8 digits of your InstanceID?

DreadPirate posted this 12 August 2017

Ok so don't you love it when you post a question then end up solving the issue right after you post it?

So for anyone who may need this information in the future... this was a permissions issue. I have my AMP Instance Store setup as "T:\AmpFiles" I DID have an NTFS permission for "NT Authority\Network Service" on the base folder "T:\AmpFiles" (Full Control) NTFS Permissions were being inherited by the folder structure underneath the base.

Just for giggles, I opened the NTFS permissions of "T:\AmpFiles" and I forced them to propagate to all child files and folders. This actually fixed my issue... even thought any "Effective Permission" validate showed "Network Service" as having Full Control on any individual file within the "T:\AmpFiles" structure.

This is great... except when I created a new instance within AMP, I had to run the process outlined above again to get the second instance to run properly. So while this issue is solved, there may need to be some work done on NTFS permissions when a new instance is created.

One last note: you DO NOT need to create an HTTP binding using netsh for AMP Instances to run as a service. "Network Service" should have the needed permissions to bind to ports automagically.

Hopefully this helps someone who may be in the same boat.

Mike posted this 12 August 2017

Humour me anyway and give me the last part of the instance ID so I can lookup what AMP thought was going on so it can report the situation better.

DreadPirate posted this 13 August 2017


Here you go. I removed and reinstalled this Instance a few times during my troubleshooting... so I don't know if this ID will have any useful information, 2124c05b.

I have 4 instances up on this server, I had to reapply the option to force apply the permissions to child objects to get them working. Not sure if it is an AMP issue, Win2016 issue, or something local to my install.

If I can be of any more assistance, please let me know. Thanks!