Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

AMP is eating RAM and CPU (kswapd)

  • Last Post 11 April 2021
vsauler posted this 09 April 2021

The OS you're using and its version

Linux Server 4.19.180-1-MANJARO

The name and version of the Cubecoders product you are using. Make sure to specify the actual version, and not just that it's the 'latest' version.

A description of the issue you are having.

amp user (I guess it should be related to systemd's ampinstmgr.service in some manner) is eating RAM and CPU even when ampinstmgr.service it's not launched (not enabled at boot by systemctl)

I started webadmins control panel to tweak some 7 days to die instance's config, without starting the server, just the instance, and when I stopped ampinstmgr.service I realized it kept using RAM and CPU. I observed it was kswapd0 executed by amp user.

I rebooted to see if that behaviour disappeared but it persists.

Steps to reproduce the issue (for bugs in particular)

  1. I ran systemctl start ampinstmgr.service to get webadmin control panel
  2. Open webadmin control panel
  3. Start 7 days to die instance (not server's instance)
  4. Changed some server's values (serverconfig.xml)
  5. Stop 7 days to die instance
  6. Close browser
  7. kswapd0 keeps eating ram, even rebooted

What you have tried so far to resolve the issue and what happened.

  • systemctl stop ampinstmgr.service doesn't stop the behaviour.
  • a reboot don't stop kswapd0 from starting.
  • killall -9 kswapd0 stops the behaviour but when rebooted it appears again (solves the situation, but not the cause which seems started by amp as seen in htop attached picture). EDIT: when you kill that process, everything goes fine. You can start/stop instances without CPU hunger nor RAM (it takes about 100MB RAM with ampinstmgr up so it's perfect!), the game isn't consuming excessive CPU/RAM neither. When you stop ampinstmgr RAM goes back to normal and CPU keeps on 0.0%, so it's OK.

A paste of any relevant output from the log file for a given AMP instance (where applicable).

For AMP, which application module you're using.

  • N/A

Order By: Standard | Newest | Votes
Mike posted this 10 April 2021

Please have htop show tree view with threads disabled (run htop as the AMP user and not root and it should do this for you). If no AMP processes are running then this is nothing to do with AMP itself.

vsauler posted this 11 April 2021


Mike posted this 11 April 2021

Something external has spawned an rsync process then and that is swapping. AMP does not use rsync so it may be some mod/plugin/etc that you're using that's invoking it. It's running as the amp user but it's not caused by or anything to do with AMP itself.

vsauler posted this 11 April 2021

I don't have anything installed from an out of the box amp fresh install so I think we might consider it has to be with the "combo" amp + 7 days to die server. Then, in this case we might talk of something caused by the amp "package", as the 7 days to die server per se didn't cause the kswapd0 problem by it's own.

I've tested out if the 7 days to die server by itself causes some kind of child process spawning or something but it just starts the server as it is and that's all.

I don't know what's calling rsync and why is amp user involved but I cannot say anything more than refer to what I'm seeing and that's what I've proven.

I don't know how can I "trace" the rsync call if that's possible. If anyone does, we could try to get into the problem.