Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

AMP loses the configuration after a restart..

  • Last Post 12 June 2021
  • Topic Is Solved
bizMark posted this 21 January 2020

Hi AMP Team and Community,

First of all I would like to apologize for any mistakes, my English is not always sufficient. I am running AMP (Lapetus) on a native Ubuntu 18.04.3 LTS 64-Bit system (no virtualization). There is currently one instance running with Minecraft Bedrock. Certainly this is a beginner mistake, but after a restart of the server some settings are no longer set, the following parts are affected:

  • whitelist.json is empty ( keeps the setting "white-list=true")
  • permissions.json is empty
  • The triggers in the scheduler also disappear

It also seems that the sleep mode does not work as expected. There are no error messages in the log file that I can see. As long as the server is running, the configuration is preserved. I would be very grateful for hints on how to save the settings persistently. Many thanks!

My Hardware:

  • 1x Intel(R) Core(TM) i3-9100F CPU @ 3.60GHz
  • 16 GB DDR4-RAM

Order By: Standard | Newest | Votes
Mike posted this 12 June 2021

Please don't gravedig a solved post that's over a year old. You should speak to the maintainer of the third party container you're using.

tdamgaard posted this 12 June 2021

I've got the same issue (with a dockerized version of AMP running on Unraid). Was the issue ever really resolved? Or is the workaround still the only "fix" (restoring, whitelist.json, and permissions.json after upgrade).


Scott posted this 30 June 2020


I think i can share a bit more info that may help solve the problem. I believe Minecraft loses whitelist and when the application itself is updated. If you have AMP set to update then start the server, it will lose it every time. I disabled the update on start up, but now will lose these settings when I click the orange "Update" button.

So I believe the real question is why does Minecraft replace these files with default when the orange update button is clicked? Is it something that can be fixed in AMP (by copying out and copying these files or not letting them be replaced during the upgrade), or is it something that Minecraft needs to fix?


BrixxtoN posted this 26 May 2020

I am having the same issue. If i Server restart or Service restart "service ampinstmgr restart", it resets the, whitelist.json, and permissions.json.

Linux Ubuntu 18.04 LTS

bizMark posted this 21 May 2020

At least I am not the only one with this problem - I still live with the workaround..

jtok posted this 21 May 2020

I am having the same issue. Fresh install of Ubuntu Server 20.04 with only amp. If i restart, it resets the, whitelist.json, and permissions.json.

I created a cronjob that backups the files regularly, and then restores from the backup at boot before

I'm at a loss as to why this is an issue, and I was hoping maybe you had found a better answer than a workaround?

bizMark posted this 31 January 2020

Good morning, great news, with the update to AMP version the problem with the Scheduler is fixed for me!

Concerning the loss of the configuration (whitelist.json and permissions.json) I am now sure that they are managed by AMP - since the update to AMP version 1.9.5.x the described files are no longer reset to 12.12.2019 00:00 (on restart) but to 17.01.2020. I am willing to do without a solution, but maybe you want to have a closer look?

Mike posted this 27 January 2020

The scheduler issue has been reported by a few people (but it doesn't seem to be universal) so its currently under investigation.

  • Liked by
  • bizMark
bizMark posted this 27 January 2020

Thanks again for the support, I will continue to follow the topic but accept the situation for the time being. It's interesting that when I launch an update of the instance everything is also reset to the initial state, so not only a reboot causes this. However, when I restart the instance, everything remains as it should.

Why the scheduler can't save the settings after a reboot. Is there any idea for this?

Mike posted this 23 January 2020

That is indeed quite the mystery! I'd be asking the Ubuntu guys for advice on that one. I'll ask around purely out of mad curiosity because that's bonkers.

bizMark posted this 22 January 2020

No problem, thanks for the support. Just for the record, it can't be the system, because other files can be stored permanently in the same directory - There must be a connection with the date - Why should the system always reset specific files to the date 12.12.2019, 00.00 o'clock? At this time the server was not yet installed..

Whatever, maybe an idea regarding the scheduler, which is also removed according to the log file?

Mike posted this 22 January 2020

This doesn't strike me as an AMP issue, but rather something more broadly wrong with your system if files contents are being reverted after a reboot - but unfortunately I have no advice for you. Something is wrong with your setup that is stopping files from being saved properly, but I have no idea what.

bizMark posted this 22 January 2020

Thank you very much for your engagement, but I can't find any errors in the log file of Minecraft, it only describes a "core-error" that the sleep mode is not available. Currently I use the workaround that I put the static files (permissions.json, whiteliste.json) into an archive, which I extract into the Minecraft root directory after restarting the server. So the server is online again in the correct configuration in no time..

Regarding the scheduled tasks, I don't have a workaround, it seems that I can't use this feature although it would be very helpful. AMP removes my triggers after a restart. Is there a solution to this problem?

[Scheduler Warning]: Schedule contains a trigger for , but no such event exists. The module/plugin that provides this trigger may not be loaded. This trigger will be removed.

I have defined the following event trigger for testing:

  • A player joins the server (event trigger)
  • Send global title message (trigger)

Mike posted this 21 January 2020

Those two files aren't controlled by AMP. Does the Minecraft server log give any clue?

bizMark posted this 21 January 2020

I really don't get it.. i tried to change permissions (chmod) but after a reboot, there is again this "version" (12.12.2019):

-rw-r--r-- 1 amp amp 3 Dez 12 23:01 /home/amp/.ampdata/instances/Minecraft01/Minecraft/whitelist.json

If I understand this correctly, the amp user is already the owner of this file and should have write access.

Here is my log file after a restart, there is a warning shown:

[18:19:46] [ModuleLoader Info]    : ADSModule requests dependency InstanceManagerPlugin...
[18:19:46] [ModuleLoader Info]    : Loaded InstanceManagerPlugin version by CubeCoders Limited
[18:19:46] [ModuleLoader Info]    : ADSModule requests dependency SystemUserManagerPlugin...
[18:19:46] [ModuleLoader Info]    : Loaded SystemUserManagerPlugin version by CubeCoders Limited
[18:19:46] [Scheduler Warning]    : Schedule contains a trigger for , but no such event exists. The module/plugin that provides this trigger may not be loaded. This trigger will be removed.

To be honest, I would already be happy if the file whitelist.json as well as the permissions.json would not be overwritten on every reboot. Of course I would also like to use the scheduled tasks.

Many thanks for your support and greetings from Switzerland.

Mike posted this 21 January 2020

You want to make a change to the schedule and then see what happens in the log. The whitelist.json and permissions.json aren't anything to do with AMP itself, they're controlled by the Minecraft server.

Usually this kind of thing means disk is full, a permissions issue, or the applications otherwise can't write their data.

bizMark posted this 21 January 2020

Thanks for the feedback regarding sleep mode, I can live with that.. Concerning the other problem I have activated the debug logging and have no new findings from the logs.


The only thing I notice is that when I restart the server, all data was last changed as of 12.12.2019 00:00. This can't be because I installed the server in January 2020.

What do you think would be useful to examine? Many thanks for your support

Mike posted this 21 January 2020

Sleep mode isn't supported with Bedrock, only Java edition. Please check your logs for any issues: