Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

AMP McMyAdmin Scheduler not working

  • Last Post 02 January 2020
oversea posted this 17 December 2019

Hi AMP Team and Community,

I am running AMP on a native Ubuntu 18.04.3 LTS 64-Bit system (no virtualization) with the McMyAdmin Module. We're playing Minecraft Forge 1.7.10- with openjdk version 1.8.0 222.

The Server is running fine, but the scheduler is not doing anything.

What I do:
- Click on Schedule button
- Click on Add new trigger
- Click on Advanced Interval
- Use the pre-configured 5-minute-time-interval and click on Add Trigger, then Add Trigger
- Then I click on Add new task
- I choose "Write unsaved world data to disk (save-all) - just to test and get a console output - from the dropdown menu
- I click on Add Task

What I expect to happen:
- At the next full five minute time (next one is 2:30 pm, then should be 2:35 pm and so on) the console should generate an output like: Server thread/INFO Saving... Saved the world

What happens:
- Nothing.

What I already tried:
- Restart the minecraft server, restart the AMP instance, restart the whole hardware server
- tried to inject a server command via tmux send -t AMPminecraft.0 save-all ENTER
- Look into the minecraft logs and forge server logs, but nothing inside
- Try another task from the dropdown, but none of them work

My Hardware:
- Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz
- 20 GB DDR3-RAM (16 GB used for Java)

Thank you for your help!

  • Liked by
  • DarkestEra
  • tbone
Order By: Standard | Newest | Votes
oversea posted this 18 December 2019

Edit: After updating this morning the scheduler is still not working.

As a workaround I managed to get the AMP API working for me to run console commands. I built a bash script with the commands I need and now I run them via API/shellscript/cron.

Anyway: Would be nice to get the Scheduler function working. :)

Edit: With the API use the login call with rememberMe set to true. It shows you the session ID. Then use sth. like this:

curl -s -d '{"SESSIONID":"abcdefgh-1234-5678-9101-iklmnopqrstu","message":"say APITEST"}' -H "Accept: application/json" -X POST http://localhost:8080/API/Core/SendConsoleMessage > /dev/null

  • Liked by
  • tbone
tbone posted this 18 December 2019

I think I'm having the same issue, except I created a scheduled task every 15 minutes, running on Windows Server, and using latest Spigot. When you call the 'save-all' function, should that cause text to be written to the chat in-game? I remember it did with McMyAdmin, but I'm new to AMP and still learning.

I was going to try to create an additional task to just write a message to the chat, but I doubt that will work either and wouldn't solve the problem anyways.

Thanks for the workaround, I will have to try that tonight, but it'd be great to get the scheduler fixed..

mojojuju posted this 31 December 2019

I'm having the same problem.

My setup:

AMP v1.9.1.2 installed using automated install script Ubuntu 18.04 in an LXC container

What doesn''t work:

Add New Trigger > Advanced Interval > Every minute (or any interval) > "Send a Message to Everyone on the Server" or "Take a backup".

Sending messages or taking backups can be done manually or when triggered by events such as when a user logs in. It's just the scheduler that doesn't work.

Mike posted this 02 January 2020

Just been looking into this, the only reason this would fail is if AMP didn't know the server was running, so it won't try and send a save-all etc. I've dropped in some extra logging so you'll be able to see more of what's happening.

Can this issue be reproduced on any other modules?