Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

AMP Mod Pack installation

  • Last Post 13 September 2019
Larkum posted this 13 September 2019


A little background, I have created a ubuntu server running on an old Mac Mini, this is a trial system that I have setup before my new (Second hand server arrives), my plan is to self host a selection of game servers from my home, rather than spending hundreds in hosting fees.

I have a working Factorio server running, and now looking at Minecraft.

I am having issues and can't work out how to add custom mod packs, I would like to start an 'All The Mods 3 Remix' server within AMP.

my issues started when I tried uploading the files, but it is a large mod and amp can't handle the upload, I have broken it up into chunks and then even uploaded everything individulay which took a long time.

Once uploaded it all went even further wrong, and wouldn't start, spitting out loads of errors relating to Java and stating loads of modulus were not installed, so I went back to basics and uploaded the server files via FTP to my server and started it via ssh and it works great.

I have a few requests, Please can you add FTP management into AM, this would make file upload a lot more smother.

As a work around I thought I would try and install Tekkit, but it seems to be broken, I then tried to install Forge 1.12.2- which is the same version as the 'All the mods 3 remix' mod pack, this also failed as it installs forge installer 1.1- which is the wrong one.

Are these known issues?

Regards Larkum

Larkum posted this 13 September 2019

So, I have found an issue that was my fault which I have now fixed, this has a server running,

I have also created a work around for FTP access, I changed the default password for the user AMP, and I sftp'ed into the server and navigated to the instance directory to upload the required files.