Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

AMP not starting due to Mono issue

  • Last Post 20 January 2020
  • Topic Is Solved
dsaksa1 posted this 04 March 2019

Title gives away the good stuff. In any case I can't get ampinstmgr to run due to some issue with Mono. Any ideas on how to remedy this? It was working fine before, but any number of issues could have broken it. I tried to look some stuff up on Google but couldn't find much. I also tried reinstalling with your script to no avail.

Error loading shared library: /tmp/mono-bundle-e9cupG/libsqlite3 /tmp/mono-bundle-e9cupG/libsqlite3: failed to map segment from shared object

Running Ubuntu 18.04.2 LTS and the latest from your repo.

Order By: Standard | Newest | Votes
Mike posted this 06 March 2019

As a sanity check, do you have any pending system updates and can you perform a reboot? AMP doesn't actually use Mono per-se (hence why its not a dependency)

dsaksa1 posted this 08 March 2019

I did, but they were unrelated and I've done a full reboot and still see a similar error.

Mike posted this 10 March 2019

Googling suggests it may be a permissions error with the temp directory, but this appears to be an issue with your system rather than AMP. Sanity check would be to try on a new but very similar system.

dsaksa1 posted this 16 March 2019

I was able to get it running, but not on the system-wide level (not sure if that's proper terminology but). I logged in as the AMP user, went into the home directory and ran ./ampinstmgr and that worked. But then trying to run ampinstmgr prompted me for options to run a mono program

Usage is: mono [options] program [program-options]

Not sure if this helps to debug anything for you.

Mike posted this 16 March 2019

You've not been trying to strip the binary or use some random pre-built image are you?

dsaksa1 posted this 16 March 2019

Not that I'm aware of, for both questions. I had to look up what binary stripping even means. I just followed the install guide on the site. ¯\(ツ)

Mike posted this 17 March 2019

You've got multiple installations at once I think, because "./ampinstmgr" is the old way of running things. Are you using a stock OS image or one provided for you by a server provider?

dsaksa1 posted this 22 March 2019

I'm using a stock install of Ubuntu. It's a bare metal server. I had originally tried to use AMP with Docker but ran into a lot of issues.

Any suggestions on the best way to remove this older version?

Mike posted this 24 March 2019

Do you have anything other than AMP installed? If your setup is that old it may be easier to back up your instance data and start again.

dsaksa1 posted this 26 March 2019

I removed the entire AMP user (and their data) and also purged ampinstmgr from the system. I then reused the quick installer and it still throws the same errors. My /tmp directory is set correctly according to what I'm reading. Does AMP require something weird like removing the sticky bit?

I also ran chmod a=rwx,o+t /tmp to be sure that my /tmp directory is set correctly.

Still seeing the same error though, even when running the simple installer.

> Adding firewall rules... Skipping adding existing rule Skipping adding
> existing rule (v6) Creating default instance... Error loading shared
> library: /tmp/mono-bundle-nw7tUE/libsqlite3
> /tmp/mono-bundle-nw7tUE/libsqlite3: failed to map segment from shared
> object Installation complete!
> You can now reach AMP at [localIP]:8080

Sorry, I'm not trying to be a pain, just trying to get this working. Any other ideas or suggestions?

phiomet posted this 20 January 2020

If anyone run in this, here is possible solution:

grep noexec /etc/fstab

If there is a noexec for the tmp directory, remove it. Something like:

tmpfs                                           /tmp                    tmpfs           defaults,noatime,nosuid,nodev,noexec,mode=1777          0       0

Must be:

tmpfs                                           /tmp                    tmpfs           defaults,noatime,nosuid,nodev,mode=1777          0       0

Then reboot.

It help me. The install script should check this, but it didn´t because of a little bug:

CCL/Mikeheute um 16:00 Uhr aah there's a tiny tiny bug in getamp that stops that check working xD grep -ice should be grep -icE

  • Liked by
  • frybread
  • seeker2921