Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

AMP Remote Instance Error

  • Last Post 26 April 2020
  • Topic Is Solved
rostw posted this 01 February 2020

OS Name/Version: Ubuntu 18.04.4 LTS

Product Name/Version: AMP - Fresh First time install

Problem Description: When attempting to manage a new instance, I get the error "Failed to login to remote instance, Login server unreachable. Verify that the auth server URL in this instances config file is valid."

Actions taken to resolve so far:

  • Restarted PC/Amp
  • Checked configuration, and yes, the auth server URL is correctly set to https, and port 8080, which is how the web server is configured.
  • Created a fresh instance, for both MC and CSGO
  • Attempted to connect from a computer both inside and outside of the local network
  • List item



Posting my solution for anyone else that comes across this, since though some help through discord we figured it out. In the AMPConfig.conf file for my instance, my Login.AuthServerURL= was set to, Which left me stuck in an infinite loading loop. By changing this value to, I was then able to manage my instance as expected.

Order By: Standard | Newest | Votes
ebreteps posted this 26 April 2020

I had this problem, which I think was caused by using the IP address for the HTTPS server URL. In that case the URL wouldn't match the HTTPS certificate, so it wouldn't connect. Changing /home/amp/.ampdata/instances/Minecraft01/AMPConfig.conf Login.AuthServerURL= to the a URL with the hostname that matches the HTTPS certificate appears to have fixed it. (The hostname is in /etc/hosts - so gets around the hostname being for both a public and private IP address.)

Mike posted this 02 February 2020

Go into the browsers network log (F12) and see what it's unhappy about. Sometimes CTRL+F5 is all that's needed, but otherwise it's a bad configuration somewhere.

rostw posted this 01 February 2020

Removing the port fixed that issue, however now im stuck on a permanant loading screen. I've managed to get past it once just by waiting, however it took almost 10 minutes, and my other 5 attempts have just gotten stuck. Tried restarting all the instances, to no avail.

Mike posted this 01 February 2020

Did you use AMPs automated https setup? If so you shouldn't be telling the instances to connect on port 8080 unless they're connected directly to localhost. If they're using the domain name then there's no port.