Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Application is not installed. /AMP/factorio/bin/x64/factorio does not exist.

  • Last Post 29 May 2021
shak posted this 24 May 2021

OS Name/Version: Ubuntu Server 18.04.5

Product Name/Version: AMP

Problem Description: Unable to start Factorio instance via ADS.

Steps to reproduce:

  1. Create a Factorio Instance
  2. Update Factorio Instance
  3. Try to start Factorio Instance
  4. Witness error

Application is not installed. /AMP/factorio/bin/x64/factorio does not exist.

Actions taken to resolve so far:

I attempted to create an instance via the command line (using ampinstmgr) but that was also no bueno. I've tried starting the instance before updating, deleting the instance and recreating, I've searched through all the config pages for a place to enter my steam credentials. Still no-go.

Note: At no point does AMP ask me for my steam credentials. I am not even sure when or where it is supposed to do this as I am not seeing any prompt and I cannot find any documentation on it.

I read around these forums that there used to be an issue with Factorio and that people had to download the latest nightly build, but these were from a long time ago so I assume that fix is now in the mainline release.

Order By: Standard | Newest | Votes
Mike posted this 24 May 2021

On Linux, AMP doesn't use Steam to download the Factorio server.

Can you try running it as a non docker instance for comparison?

shak posted this 24 May 2021

I disabled creating instances in docker containers and tried again. This seems to have worked, as I can connect to the server now. Any idea on why it wouldn't work in docker containers?

Mike posted this 24 May 2021

My guess would be some missing dependency. I'd need more information though which is a little tricky in that situation.

shak posted this 29 May 2021

Hmm, yeah I checked around the docker container created by AMP for that factorio instance and I wasn't able to find any useful logs. Was there anywhere in particular you think I should look?