Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

ARK instance not working as expected | Server not showing

  • Last Post 31 July 2019
ResidentEpiczz posted this 19 July 2019

OS: Linux, Ubuntu Server 18.04

CubeCoders AMP v1.8.2.2, built 05/07/2019 11:38

ARK Server running on ports:

Game port: 7777 / UDP

Query port: 27015 / TCP

RCON port: 34197 / TCP

First I created an instance for an ARK Server. I have adjusted a number of default settings for the server and started the server. The server is not displayed in the game or in the server explorer. I also cannot see the server if I connect directly via LAN. I also asked this before in the discord but every time it is eventually ignored.

  • I have added the ports to my firewall
  • I have completely disabled the firewall
  • I port forwarded the ports
  • Turned on debug logging

When I executed the following commands this happend:

netstat -lntu | grep 7777

Blank, nothing showed

netstat -lntu | grep 27015

udp 0 0*

Its very weird that it says UDP and the port settings say TCP

netstat -lntu | grep 34197

tcp 0 0*

Latest log file for ARK01 instance

Order By: Standard | Newest | Votes
Mike posted this 22 July 2019

In debug mode, AMP will log what arguments it's starting ARK with.

Run ARK with those exact same arguments manually outside of AMP and see if you get any log output from the game server directly that would point to the fault.

  • Liked by
  • ResidentEpiczz
ResidentEpiczz posted this 22 July 2019

Thanks for the answer. I just don't know for sure what and where to execute the code. Would you please give me an example?

Mike posted this 22 July 2019

You'd run it as-is from the Directory AMP created with the ARK server in. The log will also tell you where that can be found.

ResidentEpiczz posted this 22 July 2019

I've only been using linux for a few months now so I certainly don't know everything, this is all I can think about. What am I doing wrong?

Console image

ResidentEpiczz posted this 31 July 2019

I also asked this before in the discord but every time it is eventually ignored

And now again... The only answer I can mark right now is: "Just use arkmanager on linux instead of amp"

This is the umpteenth time that I am not being helped any further. Is it my fault that I don't know exactly what to do? Is it too advanced for me? Okay, techsupport just won't respond anymore.

Then another point, things are promised that will not be realized. for example another post on this forum named: "ARK AMP Instance Basically Has 5% Of The Features ASM Ark Manager Can Give"

But they will all be added soon.

2 years later now and still not much settings are added. and also you have to manualy install the mods etc.

I am also a programmer myself and know that things are very difficult to plan and that other problems often have to be solved first. So just tell your users honestly that it can take another 2 - 3 years or that you have no indication at all instead of "Comming soon".

Mike posted this 31 July 2019

You need to put ./ in front to run an executable that's in the local directory - It's hard to figure out what's wrong when you don't seem particularly familiar with Linux. It's also unhelpful when you post screenshots of text rather than copy pasting the output.