Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Can't connect to Valheim server started by AMP

  • 492 Views
  • Last Post 12 December 2021
cimsihmm posted this 03 December 2021

Update: I created a new instance and the server on that instance was visible to Steam. No idea why it wasn't working on the old (identical) instance but at least it's working for me now.

OS Name/Version: Windows 10 Pro 10.0.19042 Build 19042

Product Name/Version: AMP 2.3.0.6

Problem Description: Valheim server not responding on local or internet IP

Steps to reproduce:

Start instance in AMP
Start server and wait for it to be running
Use the "connect" option in AMP
Steam's "Game Info" pops up but says "Server is not responding."

Actions taken to resolve so far:

port forwarded on router for ports 2456-2458, 5678-5679, 2224
added host to router's DMZ
added Valheim-server to Windows Firewall rules
added port forwarding to Windows Firewall
turned off Windows firewall
used LAN IP:port
used internet domain:port
checked ports are open via Port Listener and canyouseeme.org
checked which ports are being used by valheim_server using TCP View and forwarded all in firewall/router
toggled server public setting on/off/on again
Edit: I was also unable to get the vanilla standalone DS working until I added -public 1 to start_headless_server.bat - see below

Background: This is my first time using AMP, it's on a brand new mini PC with Windows 10 that's running headless on my local network. I'm administering the computer via RDP and AMP via browser on my desktop. I can connect to AMP management in my browser using mydomain.name:8080 and I have an emby server running on the same domain but I can't get a response from the Valheim server.

Edit: Using the default startheadlessserver.bat script, I was unable to get a response from the vanilla DS (running on its own unmanaged by AMP) until I added -public 1 to the startup script. From that point on the server was visible as expected.

Order By: Standard | Newest | Votes
cimsihmm posted this 04 December 2021

So to update, I noticed that the original instance had the following arguments:

-port 5678 -name "name" -world "world" -password "**********" -public "True" -savedir "Data"

The new instance has this instead:

-port 5678 -name "name" -world "world" -password "**********" -public "1" -savedir "Data"

It's the only difference I've noticed between the two instances. The first doesn't show up in Steam, the second does.

Mike posted this 04 December 2021

Sanity check, can you turn the public setting off and on again to see how it affects the arguments?

cimsihmm posted this 05 December 2021

Toggling the public setting off and then on again changes the arguments to

-port 5678 -name "name" -world "world" -password "**********" -public "True" -savedir "Data"

This results in the server not responding on Steam. Restoring a backup of the instance taken before toggling the Public setting did not result in the launch argument resetting to -public "1".

Mike posted this 06 December 2021

Change the ports in AMP to 2567 and 2457.

cimsihmm posted this 11 December 2021

Change the ports in AMP to 2567 and 2457.

Same result with the port changes - the server is visible on port 2457 with public set to "1", but is not visible on 2457 with public set to "True".

Mike posted this 12 December 2021

I can't reproduce this. I performed the following steps:

  • Created a new Valheim instance on AMP 2.3.0.6 with the name "Valheim13" (Autogenerated)
  • Managed the instance, toggled the 'Public' setting off an on.
  • Started the Valheim server
  • Checked the startup flags, confirmed that it has similar arguments: -port 2466 -name "My Valheim Server - Powered by AMP" -world "PoweredByAMP" -password "**********" -public "True" -savedir "Data"
  • Ran ampinstmgr ports Valheim13 and confirmed that the instance is listening on the expected ports.
  • Opened the Valheim game and connected to the server on port 2466.
  • Connected successfully and joined in-game.

If ampinstmgr ports shows that the game is listening then any faults lie with the firewall or some other part of the network configuration.

Close