Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Can't install Amp instance manager on ARM linux (Ubuntu 20.10 x64- Raspberry Pi 4)

  • Last Post 08 February 2021
  • Topic Is Solved
soldemeyer posted this 05 February 2021

OS Name/Version: 64-bit version of Ubuntu 20.10 ARM on a 8GB Raspberry Pi 4

Product Name/Version: CubeCoders Amp, GetAMP v1.9.0 script

Problem Description: Script fails at "nstalling instance manager..."

Steps to reproduce:

Ran the script with these selections:

Will you be running Minecraft servers on this installation? If selected, this installs the required versions of Java. [Y/n] y

Would you like AMP to be configured for use with HTTPS?

This will install nginx on your system and requires that you do not use any other web servers such as Apache on this system.

This will also create firewall rules to open ports 80 (HTTP) and 443 (HTTPS) and if applicable, add selinux rules to allow nginx to act as a reverse proxy. You also must own a domain name that resolves to [IP removed for post] (Your external IP)

Do not choose this option if you do not already own a domain.

Using this facility requires that you read and accept the LetsEncrypt terms at [Y/n] n

Actions taken to resolve so far:

I'm trying to install CubeCoders Amp on a 8GB Raspberry Pi 4 running the 64-bit version of Ubuntu 20.10. I was using the GetAMP v1.9.0 script. I original tried to use the automatic script but it failed when it reached the instance manager install with this message:

Installing instance manager... Failed to install instance manager. Aborting...

I then tried installing the instance manager manually and received this:

Err:1 debian/ ampinstmgr 2.1 404 Not Found [IP: 443] E: Failed to fetch 404 Not Found [IP: 443] E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Looking at the link in the error message, that particular .deb files appears to be missing.

Am I doing something wrong? Any help would be appreciated! Thanks!

Order By: Standard | Newest | Votes
Mike posted this 06 February 2021

Repos got reset recently, try again (I queued up a new Aarch64 build).

soldemeyer posted this 08 February 2021

Thanks, this did the trick