Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Can't manage instance on Windows 2019 server

  • Last Post 16 October 2020
  • Topic Is Solved
Masterxdk posted this 16 October 2020


OS Name/Version:
Hybrid: Ubuntu 18.04
Slave: Windows Server 2019

Product Name/Version:
AMP Release "Europa"
v2.0.7, built 16/10/2020 15:48

Problem Description:
I have two instances, one on a Ubuntu server (this is set up as a hybrid) and one on a Windows 2019 server, this is setup to communicate with the controller).

I can log into both interfaces, but cant manage the game instance through either of them.

When doing it from the hybrid server, it just get stuck in the loading screen not going anywhere (F12 network says its pending on http://IP:8080/API/ADSModule/Servers/GUID/API/Core/GetAPISpec

When doing it from the server itself, it brings up a "ADS failed to provide a login token" error.

Steps to reproduce:
- Install AMP on Ubuntu 18.04
- Set up two instances (minecraft and rust)
- Install AMP on Windows Server 2019
- Disable Windows Firewall
- Create a "The Forest" instance and then try to manage it

Actions taken to resolve so far:
- Tried to delete the instance and recreate it again (that cost me a license it seems, can that be added back perhaps)
- Repair the AMP application and restarted the server (On Windows Server 2019)

Masterxdk posted this 16 October 2020

Nevermind, problem solved :) I had to make sure the auth server was configured as default before creating the instance. So i removed the instance, set up default auth server and recreated the instance.