Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Cannot Connect to new MC Server

  • Last Post 09 December 2021
  • Topic Is Solved
Archannad posted this 06 December 2021

Hi there, recently done a post stating I was using Docker to run AMP in a container. Since then, I've moved over to using a dedicated Debian VM and have got AMP setup on there. Can connect to the WebUI, create instances, perform file transfers and everything, however I cannot connect to any servers I spin up.

OS: Debian 9.13
AMP Version:
Firewall: Unifi (Ubiquiti) with necessary ports unblocked
Error Message: Connection Timed Out

I'm most likely missing something pretty basic, but so far I've tried the following to help diagnose the issue:

"ampinstmgr ports [instance]" returns the following:


Which tells me as far as AMP is concerned it is listening to the necessary ports.

"iptables --list" returns the following: (have left out the comments)
ACCEPT tcp -- anywhere anywhere tcp dpt:http-alt
ACCEPT tcp -- anywhere anywhere tcp dpt:2223
ACCEPT udp -- anywhere anywhere udp dpt:12820
ACCEPT tcp -- anywhere anywhere tcp dpt:2224
ACCEPT tcp -- anywhere anywhere tcp dpt:25565
ACCEPT udp -- anywhere anywhere udp dpt:25565

Order By: Standard | Newest | Votes
Mike posted this 06 December 2021

Are you hosting at home or on a dedicated server? Also if this is a new VM, why such an old version of Debian?

Archannad posted this 06 December 2021

Hi Mike,

This is being hosted at home. Primary reason I'm using Debian is the fact that is the recommended version on the documentation here:

webcraft posted this 06 December 2021

Debian 11 is recommended these days. It's their latest release, see here: Debian 11 is fully supported by AMP.

webcraft posted this 06 December 2021

Maybe it's your home router blocking that port?

Archannad posted this 06 December 2021

Can confirm it's not, everything necessary is unblocked through Unifi as I've previously hosted servers on my daily driver machine for my buddies with no problem. Previously had AMP working through a docker container, but that stopped working so spun up a VM and trying to do it the supported way.

Mike posted this 06 December 2021

In that case I'd be inclined to be checking your networking for the virtual machine. It's have to be bound to the physical interface so that it has its own IP address in the same range as the host. If its in NAT mode then you won't be able to connect to stuff.

Archannad posted this 08 December 2021

Hi Mike, thanks for the advice. The VM is getting its own IP address from Unifi. - This is the VM's static IP

All of my network devices go through Unifi, so they all have the range.

Regarding the physical interface, it's bridged (br0) to the physical 1Gbe port which allows me access to the web interface from other machines on my network fine - it just seems to be the actual game server that is affected.

fafdk posted this 08 December 2021

Is the VM's static IP outside the DHCP pool range on the Unifi?

What are you using as the Hypervisor for the Debian VM?

Archannad posted this 08 December 2021

Hi fafdk, the static IP is within the DHCP range but I can confirm there are no devices that share an IP. Unifi is pretty good when it comes to usability, and while this would most definitely be incorrect in a production standpoint, it works fine at home.

As a for instance, my APs are all static, as is my main PC, Unraid and now this VM.

The hypervisor for the VM is Unraid.

fafdk posted this 08 December 2021

Thank you for the answer. Well, it is better to limit the pool range and use those IPs outside the scope, of course.

Sounds like you know what you are doing, so I'm just hinting stuff here. I'm not into Unraid myself, I run Proxmox KVM for the VM's, and I'm not running my instances in Docker on AMP. I like it simple.

Are you using VLANs on Unraid?

What does "brctl show" say on your Unraid CLI?

Your not using wifi on your Unraid, are you? If so, try to turn it off.

Archannad posted this 08 December 2021

Hi fafdk, I'm not running AMP as a docker at all (I used to, but it had too many problems) and instead running it on a full-blown Debian VM through Unraid. Since Unraid is built on Linux, I'm 99% sure it also uses KVM (sorry, I should've specified that).

As far as VLANs are concerned, I don't have any on either Unifi nor Unraid. While I know VLANing would afford better security and traffic priority, it's not something I'm particularly worried about in my home environment.

"brctl show" displays the following:

The Unraid box doesn't have a Wi-Fi module, only 1GBe

Archannad posted this 08 December 2021

Update: I've just run the Test-NetConnection command through powershell on my machine to run a TCP probe. Probe succeeds without a hitch for both the web panel (which is working) and the MC server (which isn't working....) Screenshot below:

fafdk posted this 09 December 2021

OK, thank you.

I would rebuild on the latest Debian or Ubuntu 20.04.3 LTS and make a comparison. You can always just spin up a new VM and see if that solves the problem, if it is because of outdated packages, or compatibility issues with Debian 9. It would also give you a chance to see if that solves your issues before going any further in the investigation on your current installation, you could save a lot of time.

I have had AMP running for ages on Ubuntu 20.04.* and it just works for me, in KVM with VirtIO NIC drivers. Not that I have it running on Unraid, but I don't have any other problem than my own misconfigurations. Since you can ping the WebUI on AMP, then you should be able to find the ports of MC as well, if you don't have any blocking going on, like fail2ban, IPTables, etc.

If I were you, I would spin up a fresh VM with a recent OS, install a fresh AMP and see what happens :) - and disable the firewall during installation too, you don't need it on the server. 2xNAT is not good.

  • Liked by
  • Archannad
Archannad posted this 09 December 2021

A thousand thanks! That has worked like a charm. I just setup a new Ubuntu Server 20.04.3 LTS VM and it's working fantastically.

Had to install Java manually as well as disable the firewall, but now it's all plain sailing. Thank you!

Archannad posted this 09 December 2021

@Mike it might be worth updating the documentation (if you can do that) to strike off Debian 9 as being supported, as I'm 99% sure this is what was causing the vast majority of my problems.

Cheers for your help too :)

fafdk posted this 09 December 2021

Glad that it worked for you and that you saved time :) - it might not be Debian 9 which was the culprit, it could be so many things there in Unraid, or under any other virtual system, etc.

The main fact is that you got it working and that you're happy :)

Happy Gaming!