Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

cant seem to get rcon passthrough to work

  • 47 Views
  • Last Post 15 January 2022
  • Topic Is Solved
foxtrot3000 posted this 15 January 2022

good morning, i am trying to get the rcon passthrough to work but i cant seem to get it working at all. what i did so far was installed debian 11, installed amp, installed 7 days to die on it, activated the rcon passthrough, restarted amp, tried to connect to it and it just pops up with:

telnet> open gl.*.info 7777
Trying 192.96.217.143...
Connected to GL.
*
.info
Escape character is '^]'.
Connection closed by foreign host.

and thats it. when i connect to the normal rcon port it shows everything the same but pops up asking for the password (that amp changes at every restart) instead of disconnecting me right away and the service logon password i put in doesnt work. i cant seem to find any logs indicating any connections in the amp logs for the rcon passthrough so you will have to tell me where to find them logs.

OS Name/Version: debian 11
Product Name/Version: v2.3.1, built 13/01/2022 21:16
7 Days to Die module
i am more then happy to provide the actual link if needed so you can try and telnet in if you wish so you can see what i see.
edit: i have even gone so far as to reboot the whole machine. running on a dell fc630 so not a virtual machine if that helps.

Order By: Standard | Newest | Votes
Mike posted this 15 January 2022

You're using Telnet to connect. You need to use an actual rcon client for passthru (even though the game itself uses telnet)

foxtrot3000 posted this 15 January 2022

mike, i am trying to get the mischief maker working for 7 days to die for a twitch streamer. when i try and connect to 7777 (the port for the rcon passthrough) it cant seem to connect either. when i try and connect it, it pops up saying " Unable to connect. Be sure you have the correct telnet port (found in your serverconfig.xml file) and confirm you are not blocked by Windows Defender Firewall or a third part anti-virus software." but if i change the port to 7778 it pops up saying "Game server error: Connection refused: connect" so i believe its doing the same thing that telnet is doing (connecting, getting that one line and instantly getting disconnected before anything can be typed/sent). any thoughts on what to try next?

Mike posted this 15 January 2022

Connect directly to the game itself but with a custom password set.

foxtrot3000 posted this 15 January 2022

alright, thank you

Close