Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Cant start minecraft instance as it belongs to Network Service

  • Last Post 02 July 2019
  • Topic Is Solved
S0R3 posted this 30 June 2019

OS Name/Version: Windows 10 Home

Product Name/Version: AMP Instance Manager v1.8.0.2 built 22/05/2019 10:46

Problem Description: I have two minecraft instances that I can start at all. I have tried the ADS, the GUI, and even the command line. Whenever I do the command ampinstmgr startinstance Minecraft07or ampinstmgr startinstance Minecraft05 the Command Prompt spits out this error I have even remade one of the instances completely for it to just do the same thing when I change the port.

Steps to reproduce: Before remaking the instance 1. Create instance 2. Mark as start on boot 3. Turn it off start on boot

After remaking the instance

  1. Create new instance
  2. import the server files through the ADS
  3. Change the port

Actions taken to resolve so far: I have tried upgrading one of the instances to the nightly builds, I have remaking them, I have tried re-configuring them, I have tried starting them from the system account for it to not even work.

Edit: Found a temporary fix of just changing the instance.json file to not have NETWORK SERVICE as the owner and have machinename$ as it instead

Order By: Standard | Newest | Votes
Mike posted this 01 July 2019

You need to update the instance manager command line tool itself. Just re-download the installer and run it over the top.

S0R3 posted this 01 July 2019

Thanks that fix that issue, however, when ever I make an instance it automatically starts being managed by NETWORK SERVICES. Any idea how do fix that?

Mike posted this 02 July 2019

If ADS is running as a service, then it's running as NETWORK SERVICE. So any instances it creates also belong to NETWORK SERVICE by extension.