Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Cant update Valheim (new instance)

  • Last Post 18 March 2021
rabarber posted this 18 March 2021

Im trying to start a new instance of Valheim and i cant download the application. I get this log output.

 [19:18:58] [Core Info]            : Checking for AMP updates...
[19:18:58] [Core Error]           : IOException
[19:18:58] [Core Error]           : [0] (IOException) : The file '/home/amp/.ampdata/instances/GirlPower/Valheim/' already exists.
[19:18:58] [Core Error]           :   at IO.FileLinkOrCopyFile (String sourceFullPath, String destFullPath)
  at IO.FileMoveFile (String sourceFullPath, String destFullPath)
  at IO.File.Move (String sourceFileName, String destFileName)
  at ModuleShared.Utilities.DownloadFileWithProgressAsync (String url, String filename, ModuleShared.RunningTask task, Boolean autoRemoveTask, String UserAgent, Boolean WithCloudflare)
[19:18:59] [Core Info]            : AMP is up-to-date.

I have tried to delete the Valheim folder but then the log file complains about the missing directory.

I can update the application in a different instance

rabarber posted this 18 March 2021

I think I solved it by comparing the new instances "Generic module.kvp" with an older working instance.

diff ./.ampdata/instances/Ragnark/GenericModule.kvp ./.ampdata/instances/GirlPower/GenericModule.kvp

I found that on line 37 there were differences after App.UpdateSources

Old: "UpdateSource":4 And "UpdateSourceData":"896660"

New: "UpdateSource":1 And "UpdateSourceData":""

So I manually changed the new files data to match the old and that seems to have done the trick. Update is now working.