Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

"Could not find a part of the path" when trying to delete files/folders

  • Last Post 27 January 2022
AbhorrentJoel posted this 27 December 2021

OS Name/Version: Ubuntu 20.04.3 LTS

Product Name/Version: AMP v2.3.0.8

Problem Description: When trying to delete a file or folder in an AMP instance UI, it fails to "trash" it and gives the message Could not find a part of the path '/AMP/7d2d/294420/saves/Navezgane'. (in 7 Days to Die instance, for example).

When connecting over AMP's own SFTP, it did not immediately appear to allow me to delete the folder. But after some time, it just let me do it. I am not sure what prompted it to change.

It seems to be hit or miss, since after deleting the folder and recreating it by launching the server, I could then delete it from the UI again and then successfully trash it. But after stopping and starting the instance, I could no longer delete files from the UI immediately. But after a while it just worked again. After this point, until the instance is stopped, it will continue to work without issue.

Steps to reproduce:

  • Install AMP (enable Docker for instances)
  • Create a new instance for 7 Days to Die
  • Update server (install files)
  • Start the server (Optional, unless you want to delete the same folder as I generated)
  • Attempt to delete folders/files

Actions taken to resolve so far:

  • Deleted and recreated the instance
  • Reinstalled AMP
    • This included removing ampinstmgr, deleting AMP user home folder before installing again

This is not the first time I have encountered this issue. I had this before with a Minecraft instance which would not let me delete plugins or any files for that matter, but then suddenly I could without any changes to the instance.

  • Liked by
  • Codename_11
Order By: Standard | Newest | Votes
AbhorrentJoel posted this 30 December 2021

I should add that I have enabled debugging and nothing shows up when I get this message via the Web UI. I have tried in both Firefox and Edge so far with the same result.

Codename_11 posted this 23 January 2022

I'm seeing the same thing with Ubuntu as well... Did you end up figuring anything out?

AbhorrentJoel posted this 23 January 2022

Sadly not. I've recently reinstalled the whole OS and I'm now running on AMP v2.3.1, so I will have to see whether it is still occurring.

Mike posted this 27 January 2022

Looks like that's a docker instance - what happens if you try and delete it from ADSs file manager?