Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Custom SRCDS Game

  • Last Post 08 June 2020
MikeyC04 posted this 29 May 2020

Looking to host a GoldenEye:Source server. Not looking to have anyone develop a new option or anything, but it would be nice to use the existing srcds module to host custom source games. I can't find anything related to setting the execution in any of the .kvp. Any tips on how I might achieve this as I was having issues with the generic module and srcds playing nicely (couldn't get it to actually quit) and it would be nice to use the settings available to the srcds module in the web app

Order By: Standard | Newest | Votes
Mike posted this 29 May 2020

Can it be downloaded via steamcmd?

MikeyC04 posted this 29 May 2020

Not the entire file set directly. The server uses appid 310 (Source 2007 Dedicated Server) which then you place the game files in that directory appid directory much like you see cstrike or dod ( example: ./{appid}/cstrike). so the result would be for example "./310/gesource" and you launch setting the srcds game command line arg. I was thinking it would be cool that to have a generic srcds with a variable for game and then anything else related specifically to that game you set with custom options like is in the settings now.

Mike posted this 29 May 2020

The generic module could handle that well enough.

MikeyC04 posted this 30 May 2020

The generic module is not functioning in this case. It hangs on startup, and no matter how I set the exit method it always just restarts and goes back to the same hangup. I am able to start the server outside of AMP on the machine no problem

Mike posted this 31 May 2020

Then it's misconfigured, you should have AMP produce a startup script to show you what it's doing and you can compare that to how you start it normally:

MikeyC04 posted this 08 June 2020

Went through the diagnostics wiki. Still having the same issue. And even though it is not recommended, I went through and completely reinstalled AMP, redid my ADS instance, and the generic module. I have no issue running the startup script and the startup script runs as expected. I've noticed 2 differences in SRCDS command line outputs between AMP console and the start up script output. There are 2 lines missing in AMP console, both related to reading/writing files from the disk. Unfortunately this is where I'm stuck again. I've tried making sure the file permissions are all the same throughout just to make sure it wasn't an access issue and it's still not working.