Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Error Unhandled Exception thrown on AMP Controller

  • Last Post 03 December 2020
  • Topic Is Solved posted this 02 December 2020

Debian 10 running on KVM
AMP Release "Europa"
v2.0.8.6, built 23/11/2020 19:36
After countless errors my amp controller creashes
Turn on the machine, press on instance multiple times refresh the page go to instances and after a while it      will crash
I have tried reinstalling it on 2 machines but sadly i am getting same error on both.

21:08:50] [ErrorReporter Error] : Unhandled Exception: This will be automatically reported to the AMP developers. [21:08:50] [ErrorReporter Error] : [Error] --- Begin Exception Data --- [Error] OS: Linux (x8664/QEMUKVM) [Error] Module: ADSModule, Version: AMP [Error] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV [Error] Instance ID: 76b4c987-43c1-47a5-8f2b-5f112ebe938d [Error] AutoMapperMappingException [Error] [0] (AutoMapperMappingException) : Error mapping types.

Mapping types: IEnumerable1 -> IEnumerable1 System.Collections.Generic.IEnumerable1[[InstanceManagerPlugin.AMPInstanceBase, InstanceManagerPlugin, Version=, Culture=neutral, PublicKeyToken=null]] -> System.Collections.Generic.IEnumerable1[[InstanceManagerPlugin.InstanceSummary, InstanceManagerPlugin, Version=, Culture=neutral, PublicKeyToken=null]] [Error] at InstanceManagerPlugin.InstanceSummary.UpdateFrom (Collections.Generic.IEnumerable1[T] Source, Collections.Generic.IEnumerable1[T] Destination) at ADSModule.RemoteADSController.UpdateRemoteInstancesList (ADSModule.RemoteADSInstance Instance) at ADSModule.RemoteADSController.UpdateSingle (Guid Id) [Error] InvalidOperationException [Error] [1] (InvalidOperationException) : Collection was modified; enumeration operation may not execute. [Error] at Collections.Generic.List1+Enumerator[T].MoveNextRare () at Collections.Generic.List1+Enumerator[T].MoveNext () [Error] --- End Exception Data ---

in second log file this issue did not happen but it has stopped without sending an error report: [21:45:00] [APIService:Anonymous Warning] : Access denied: You do not have permission to use this method (ADSModule.GetInstances) at this time. This method requires the Session.LoggedIn permission. (Origin:

Controller at Nginx with SSL, Other servers pointing to it. this happens with > 2 Nodes connected to it.

Order By: Standard | Newest | Votes
Mike posted this 02 December 2020

Are your targets also up to date? posted this 03 December 2020

Yes they're all up to date, updated & upgraded debian 10. the Crash became less frequent but it still happens when creating instances on the Nodes.

Mike posted this 03 December 2020

I shall look into it when I'm back working on Monday (hopefully)

  • Liked by