Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Error when running CLI for in Windows

  • Last Post 06 March 2021
  • Topic Is Solved
jrsrjrsr posted this 28 February 2021

OS Name/Version: Win 10, 2004 (19041.804)

Product Name/Version: AMP

Problem Description: The following error message is returned when running ampinstmgr:

Unhandled Exception: System.TypeLoadException: Method 'CreateTask' in type 'InstanceManagerCLI.ConsoleTaskManager' from assembly 'InstanceManagerCLI, Version=, Culture=neutral, PublicKeyToken=null' does not have an implementation.
   at InstanceManagerCLI.Core.Run()
   at InstanceManagerCLI.Program.Main()`

This started after installing from the .msi download.

Note that all my instances are running fine because they are still running I was trying to upgrade the instances via ampinstmgr upgradeall when I first saw the above message. Also, the command ampinstmgr -h returns the same message.

Order By: Standard | Newest | Votes
jrsrjrsr posted this 06 March 2021

I ran in repair mode and then upgraded all instances to I am no longer having the above problem.

Unfortunately, I have a new problem...

The ADS instance (installed as service) does not seem to be running correctly. The service shows as running in the Windows Service Manager and ampinstmgr -l, but I cannot connect to it and no start up messages show up in the log file when I try to restart. I will submit a separate forum message about this issue.

Mike posted this 28 February 2021

Run the installer in repair mode then reboot.