Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Fresh install on Fresh Ubuntu says: "Your AMP instance could not be connected to"

  • 157 Views
  • Last Post 16 December 2020
bushcrafters posted this 16 December 2020

OS Name/Version:

Ubuntu 18.04

Product Name/Version:

AMP Instance Manager v2.0.8.10

Problem Description:

The following errors showed up during install:

Creating default instance...
[Info] AMP Instance Manager v2.0.8.10 built 15/12/2020 17:10
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
'127.0.0.1' is not a valid value for the 'Port' argument.
[Error] IM was unable to execute the requested command.
[Error] TargetParameterCountException
[Error] [0] (TargetParameterCountException) : Number of parameters specified does not match the        expected number.
[Error]   at InstanceManagerCLI.Core.ExecuteCommand (Collections.Generic.List`1[T] Params, Coll       ections.Generic.Dictionary`2[TKey,TValue] Args)
Installation complete!
You can now reach AMP at https://mysite.com/

When you go to mysite.com, it says:

AMP is not currently running

Your AMP instance could not be connected to, this likely means that it is not running.

The service status:

● ampinstmgr.service - AMP Instance Manager
   Loaded: loaded (/etc/systemd/system/ampinstmgr.service; enabled; vendor preset: enabled)
   Active: active (exited) since Wed 2020-12-16 19:25:53 GMT; 7min ago
     Docs: https://github.com/CubeCoders/AMP/wiki/AMP-systemd-script-(Linux)
  Process: 29717 ExecStop=/opt/cubecoders/amp/ampinstmgr stopall (code=exited, status=0/SUCCESS)
  Process: 29762 ExecStart=/opt/cubecoders/amp/ampinstmgr startboot (code=exited, status=0/SUCCESS)
 Main PID: 29762 (code=exited, status=0/SUCCESS)

I could not find any logs, /home/amp/ is empty. Not sure what to do from here.

Actions taken to resolve so far:

  • Fresh install of Ubuntu 18.04, reinstalled using script.
  • Tried manually applying the firewall rules: sudo ufw allow from any to any port 8080 proto tcp which returned: Skipping adding existing rule

Mike posted this 16 December 2020

When it first asks you for a panel password, use a plain alphanumeric password with no spaces.

A recent change broke handling of complex passwords during setup, it's being fixed. Using a simpler one is a workaround (you can change it to a more complex one in the web interface after)

Close