Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Help Setting up SRCDS

  • Last Post 24 December 2017
  • Topic Is Solved
cwagz posted this 18 December 2017


I have installed an instance for srcds. Trying to setup a CS:S server. Everything appears to have downloaded correctly but when I start the instance it immediately dies. The error in the srcds console window is: failed to find steam.inf or equivalent steam info.

I am running in Windows 10 inside Hyper-V


my instances are running on a network share (this has worked fine for Minecraft)

Any help is appreciated.

Thanks, Chad

Order By: Standard | Newest | Votes
Mike posted this 18 December 2017

Is the instance configured to run as a service?

cwagz posted this 18 December 2017

The instance is running as a service.


Mike posted this 21 December 2017

Everything I can find for this error suggests that just a reinstall is required. I'd suggest deleting the numbered directory with the game data in and letting steamcmd download it all again (hit the Update button in AMP again)

cwagz posted this 24 December 2017

Thanks Mike - I tried re-installing but got the same error.

I moved my instance folder back to my C drive and everything works now.

Something must not like the network path I was using for my instance folder location.

Mike posted this 24 December 2017

There's a cheat way around this assuming that you're just using a network drive in this case for storage and aren't actually sharing your instance data between machines.

You can create a virtual hard disk image on your network share, mount that image as a local drive, and install onto that. Applications don't ever know they're stored on a remote system and won't complain.

The other option is what we do here in house very often and have a file server act as an iSCSI target and use that for mass remote storage.

cwagz posted this 24 December 2017

Thanks Mike! That is a great suggestion. I think I will setup a VHD.

cwagz posted this 24 December 2017

I have a VHDX sitting where I want on my server now. This is working great.

The only issue I see is that when I hit stop in AMP the server does not actually stop. Kill does not work either. I have to go into Task Manager and end task on srcds.exe in order to get the server to stop so I can tweak my server.cfg file.

Mike posted this 24 December 2017

AMP relies on RCON to issue the shutdown command so you'll wanna check AMPs log and see if it's running into any difficulties doing that.

cwagz posted this 24 December 2017

RCON password is bad. Forgive me if I am missing something simple but where do I put the RCON password in AMP? I see how to put it into server.cfg but do not see the place in AMP.


cwagz posted this 24 December 2017

I figured it out. I just needed to comment out the rcon_password line from the server.cfg. I guess this prevented AMP from setting it's own password.

Mike posted this 24 December 2017

Indeed AMP overrides RCON, what you can do is enable RCON Passthrough in the RCONPlugin.kvp file and use an RCON client that way.