Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

How do I connect my existing minecraft server to mcmyadmin?

  • Last Post 17 March 2019
  • Topic Is Solved
wileazy posted this 12 March 2019

I have a Forge minecraft modpack server (SkyFactory 3) which I want to monitor with mcmyadmin but I can't see how I link my current server. Is this possible?

Thanks in advance!

Order By: Standard | Newest | Votes
Mike posted this 12 March 2019

You just need to move your existing Minecraft server into the Minecraft directory where McMyAdmin is installed, and then McMyAdmin will start it. You may need to rename the jar file depending on what type of server you're using or what version of McMyAdmin you're using.

wileazy posted this 13 March 2019

Thanks for the fast reply!

Great answer only I need mcmyadmin to run the .bat file because of the ram and other commands I gave it. Any advice on that?

Mike posted this 13 March 2019

You don't need the bat file. Any custom arguments can go in the CustomOpts flag in McMyAdmin.conf / MinecraftModule.kvp

wileazy posted this 13 March 2019

Thanks for helping :D

Found it, tried it, still not working. My mods are rejected and the terminal shows an error of every non-vanilla block/item/entity. It's a full modded server(around 180 mods), no plugins.

Mike posted this 13 March 2019

Then you've got the flags wrong, or you're starting the wrong jar file.

wileazy posted this 13 March 2019

I emptied the minecraft folder in the %appadata%/local/mcmyadmin folder.

Copied my entire server into that folder.

Edited the file mcmyadmin.conf, gave the server a bit more RAM and added after the

Java.CustomOpts=-XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing XX:+CMSClassUnloadingEnabled -XX:ParallelGCThreads=2 -XX:+AggressiveOpts -XX:MinHeapFreeRatio=5 XX:MaxHeapFreeRatio=10

Renamed the minecraftskyfactoryblabla.jar file to minecraftserver.jar

Did I miss something?

Mike posted this 14 March 2019

That should be fine - check in MCMAs log file to get the full list of flags its starting the server with.

wileazy posted this 15 March 2019

This is piece of my log file:

Notice  : Detecting System...
Notice  : Windows Version: Microsoft Windows 10 Pro(64 bits)
Error   : Hamachi Detected - You may not be able to remotely access McMyAdmin on systems without Hamachi installed
Notice  : Detection complete.
Notice  : Detected Java runtime version 1.8.0
Error   : McMyAdmin was not shut down properly!
Error   : To avoid potential data loss, please perform /quit on this console.
Error   : Startup will resume in 5 seconds...
Notice  : Starting McMyAdmin Personal v2.7.1.0
Notice  : Checking for updates...
Notice  : Checking for Minecraft Server updates...
Notice  : Starting webserver...
Notice  : McMyAdmin has started and is ready for use.
Notice  : Server jar hash is 81e0c441-fdde-b080-9cb0-391c894c2f3c
Notice  : Starting Minecraft Server...
Console : [10:20:43] [Server thread/INFO]: Starting minecraft server version 1.10.2
Console : [10:20:43] [Server thread/INFO]: Loading properties
Console : [10:20:43] [Server thread/INFO]: Default game type: SURVIVAL
Console : [10:20:43] [Server thread/INFO]: Generating keypair
Console : [10:20:44] [Server thread/INFO]: Starting Minecraft server on *:25565
Console : [10:20:44] [Server thread/INFO]: Using default channel type
Console : [10:20:44] [Server thread/INFO]: Preparing level "world"
Console : [10:20:44] [Server thread/INFO]: Preparing start region for level 0
Console : [10:20:45] [Server thread/WARN]: Skipping BlockEntity with id blockConduitBundleTileEntity

And the last line continues for another 4073 times (according to notepad). I don't see anything about the flags. It loads the correct version of minecraft just not the mods. When I keep it running it just says Vanilla mineraft server on my client. Has this something to do with that I'm running the free version?

wileazy posted this 17 March 2019

I found it. I had to go to the settings-tab and switched from official to FTB and rename the forge.jar. It then loaded correctly. Thanks for all the help!