Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Issues running a server for the Valhelsia 2 Minecraft Modpack

  • Last Post 18 September 2020
MonkeeLord posted this 15 September 2020

Hi there,

I've put together a server machine I keep at home and I've tried to put together a Minecraft server using the modpack 'Valhelsia 2' but have run into several issues.

These questions may be rather Minecraft related, but I'm seeking help here since the server runs perfectly well when run from a batch file outside of AMP. (AMP is running on a Windows Server 2016 machine)

Since Valhelsia 2 is a relatively new modpack on the Twitch launcher and isn't on the old FTB launcher, there is no specific preset config available for it when setting up an AMP instance (unless I'm missing it), so I've had to do some serious mental gymnastics trying to get it to work.

The primary issue is that the server simply will not stay up for much longer than 30 seconds. I have tried using the Official (Vanilla) option while setting the version to 1.15.2, I have tried using the 'Custom' option (while trying my hardest to input the correct custom arguments), and I have tried using the 'forge' option while setting the version to the version of forge Valhelsia 2 uses.

With all of these methods, I have pointed the instance to the forge Jar file in the server directory, but the server will either stop within 5 seconds and won't use any system resources, or it will begin to use system resources for less than a minute and will eventually crash when trying to load a certain mod, which is sometimes a different mod each time. (I experienced a near-identical issue to this when trying to run the server on Ubuntu Server)

The server currently has 6GB of RAM allocated.

Hope someone out there can help, would be disappointed to know I can't use AMP.

Thanks in advance, - Matt

Farken_OJ posted this 18 September 2020

Hi MonkeeLord,

I running a home ubuntu server with 12 GB allocated to my Valhelsia 2.

The way I got it to work was:

  • Creating a new minecraft Instance
  • Dragging the Valhelsia 2 server files to the instance file manager
  • Extracted the Zip (make sure its not in one folder and the files are in the root)
  • In Config/minecraft select server type Feed The Beast
  • I selected FTB Academy (Don't press Download/Update)
  • Select the forge jar in the Server Jar section
  • Then run the server

This stuff worked for me, I hope this helps