Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Migrated from McMyAdmin to AMP, cannot connect to server anymore

  • Last Post 08 July 2020
  • Topic Is Solved
Valrek777 posted this 08 July 2020

OS Name/Version: Windows 10 version 10.0.18363 Build 18363

Product Name/Version: AMP v1.9.9.10 "Lapetus"

Problem description:

I was importing my server from McMyAdmin to AMP, following these instructions ( I cannot connect to the server at all unless I use direct connect If I or anyone else tries to connect in any other way, this error message pops up via minecraft:$annotatedconnectexception: connection timed out: no further error

Steps to reproduce:

Create functional minecraft server in McMyAdmin Follow steps in exactly Atempt to connect via minecraft (doesn't work) Connect via local IPv4 address (works)

Actions taken to resolve so far:

I see no errors from AMP stating anything is wrong on that end. I've tried going into the Configuration>SMTP Settings menu and typing in my public IP as the server address and 25565 as the server port.

I don't know what else to do/don't want to mess with anything further in case I make it worse. Any help is appreciated!

Order By: Standard | Newest | Votes
Mike posted this 08 July 2020

Either your firewall or port forwarding rules are wrong.

  • Liked by
  • Valrek777
Valrek777 posted this 08 July 2020

EDIT: I typed in the wrong IP for the port forwarding, you were right! Just took me a while to see it. Thank you very much!

I ran ampinstmgr ports 'Instancename' and here is the result:

Microsoft Windows [Version 10.0.18363.900] (c) 2019 Microsoft Corporation. All rights reserved.

D:\AMPDatastore\Instances\ADS01>ampinstmgr ports Minecraft01 [Info] AMP Instance Manager v1.9.9.10 built 23/06/2020 23:20 [Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV [Info] Port usage for Minecraft01 (Minecraft01) [Info] Instance is currently not running. [Info] LISTENING 8081 TCP (Core.Webserver.Port) [Info] CLOSED 25565 Both
(MinecraftModule.Minecraft.PortNumber) [Warning] Some of the ports required by this instance are currently in use, which will prevent this instance from functioning correctly.


I don't understand how to see what's using the port or how to change that.