Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Minecraft Docker instance won't start

  • Last Post 07 March 2019
DarkSylph posted this 03 March 2019

OS Name/Version: CentOS Linux 7

Product Name/Version: AMP version (Hawking Starman)

Problem Description: Creating a new instance with Docker enabled leads to the instance not starting

Steps to reproduce:

  • Turn on Docker support in ADS.
  • Create new Minecraft Java Edition instance.
  • Start.
  • Error.

Actions taken to resolve so far:

  • Deleted and recreated instance multiple times
  • Confirmed the AMP user is in the docker group
  • Restarted ADS

Order By: Standard | Newest | Votes
Mike posted this 03 March 2019

Have you logged out the session that AMP was started in since adding the AMP user to the docker group?

DarkSylph posted this 03 March 2019

I added the AMP user to the docker group before installing AMP. I did it shortly after setting up docker, but before downloading the ampinstmgr.

I can try restarting the server to see if you think that will help.

Mike posted this 03 March 2019

Worth a shot, also you can do the following:

AMP_LOG_LEVEL=0 ampinstmgr ....

To enable debug logging of any command, which will include things like what command its giving to docker.

DarkSylph posted this 03 March 2019

I did that, ran the command, copied it and pasted it into pastebin, and attached to case under Log files. It's the link at the end.

Mike posted this 03 March 2019

And what happens if you try manually starting docker using the same flags?

DarkSylph posted this 03 March 2019

I was actually wondering if I could do that. Since the logs show the exact docker command being run, can I copy and paste that and run it myself manually? Of course, I'd run it as the AMP user.

If I did that, would AMP still pick that up and work with it? Assuming it builds correctly.

Mike posted this 04 March 2019

It will work with it, but this is more just to see what happens. You can also swap out -d with -it

DarkSylph posted this 04 March 2019

I just created a new Minecraft instance with Docker support inside ADS. I checked in docker and it shows the container created and running, but when I try to hit "start instance" I get the same error as before.

However, since I can see the container is running now, which it wasn't before today, I waited, refresh, and noticed the instance now showed as running.

So the error it gave wasn't accurate just now. "Task Starting Instance (Starting Docker-Test (Minecraft02)...) failed:"

Inside the new instance there is an error "[15:59:30] [Minecraft Warning] ???: Failed to get latest forge version data. The remote server returned an error: (404) Not Found."

But otherwise the docker instance appears to be working. From the logs and what happened, it looks to me that simply creating the docker instance also auto-runs the container, instead of waiting for me to hit start.

Mike posted this 04 March 2019

AMP uses disposable containers, they're dynamically created and destroyed every time the instance is started/stopped.

DarkSylph posted this 04 March 2019

Ah okay, makes sense. When creating new instances with docker, should I ever worry about having to hit the start button after creation, unless the instance is actually stopped by me of course.

It looks like hitting the start button is the source of the issue for me.

Would it be possible to add a longer delay after creating the container so that instead of showing a start button, it shows manage instead? It seems like there is a delay between the container being built and ADS switching from start to manage.

Mike posted this 04 March 2019

You don't create instances with docker per-se, as soon as that instance stops it no longer exist. The container isn't 'built', it's pre-made and just fired up on-demand.

Starting it via docker was a diagnostics step, not something you should ever attempt to do manually.

Try starting the docker instance via ampinstmgr start INSTANCE and then check if its alive using ampinstmgr info INSTANCE

DarkSylph posted this 05 March 2019

It gives an error when hitting the start button from the GUI, even though in the console, it actually starts up correctly, and then a few seconds later, I can manage it without issue.

I've loaded one of my regular worlds and played with friends and it worked great. So it seems the issue is just the start button giving errors even though it's working correctly.

Mike posted this 05 March 2019

I didn't ask you to use the GUI, I just want to see what happens when you use ampinstmgr start INSTANCE on a docker instance followed by a query. I cannot reproduce your issue so I need more data.

DarkSylph posted this 06 March 2019

[AMP@ds-docker-01 ~]$ ampinstmgr start Minecraft03 [Info] AMP Instance Manager v1.7.2.6 built 31/01/2019 15:12
[Info] Release spec: Release - built by CUBECODERS/BuildBot on CCL-DEV [Info] Starting Instance: 'Minecraft03'
[Info] Web interface is listening at (removed) [Info] You can browse to this instance at (removed) [Info] Instance started in new session. Run 'ampinstmgr View Minecraft03' to view this instances console.
[AMP@ds-docker-01 ~]$ ampinstmgr info Minecraft03
[Info] AMP Instance Manager v1.7.2.6 built 31/01/2019 15:12
[Info] Release spec: Release - built by CUBECODERS/BuildBot on CCL-DEV Instance ID │ e6fdfb24-435f-4b8d-a045-307ea290084f
Module │ Minecraft
Instance Name │ Minecraft03
Friendly Name │ FTB-Revelation
IP Binding │
Port Number │ 8083
Running │ Yes
Daemon Installed │ No
Start on Boot │ No
AMP Version │
Release Stream │ Mainline
Data Path │ /home/AMP/.ampdata/instances/Minecraft03

Works perfectly without issue from the console. Anything else I can test for you?

Mike posted this 06 March 2019

Is the ADS instance running in a container?

DarkSylph posted this 07 March 2019

No. I set up ADS outside of a container. Only the game instances run in containers right now.