Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Minecraft Instance unable to start server with old world file from an MCMyAdmin

  • Last Post 24 September 2021
Joop79 posted this 23 September 2021

OS Name/Version: Windows Server 2019

Product Name/Version: AMP Release "Callisto" v2.2.0.6, built 23/08/2021 13:35

Problem Description: File permissions error preventing server start

Steps to reproduce:

Step 1: Copy server world to new Minecraft folder
Step 2: Attempt to start server
Step 3: Server fails to start

Actions taken to resolve so far:

I've use a brand new world, generated by the AMP software. Loads up and provides 0 issues. The issues occur when I copy over the old world from the MCMyAdmin software.

 I've tried to first copy the folder from the Administrator account to the AMP user documents in the hope of stripping the file permissions.  Attempted to manually change the permissions on the world folder to the AMP user account  Attempted to manually change the permissions to the NETWORK SERVICES account used by the AMP application  Changed the ‘User’ name from NETWORK SERVICES to AMP in the .json file

Order By: Standard | Newest | Votes
Mike posted this 23 September 2021

You should use AMPs SFTP to add files, if you use Windows Explorer you'll destroy your permissions every time. Don't change the owner of anything in the JSON file.

At this point you've made too many random changes. Destroy the instance and try again, using AMPs SFTP to add the files.

Joop79 posted this 23 September 2021

I solved the issue by changing the files permissions to all Users. This can be closed.

Mike posted this 24 September 2021

That's really dangerous, please don't do that - you can compromise the security of your system by doing that.