Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Minecraft Java instance will not start on Raspberry Pi 4

  • Last Post 31 March 2021
  • Topic Is Solved
soldemeyer posted this 08 February 2021

OS Name/Version: 64-bit version of Ubuntu 20.10 ARM on a 8GB Raspberry Pi 4

Product Name/Version: CubeCoders Amp

Problem Description: Minecraft Java instance will not start

Steps to reproduce:

Created a new Minecraft Java instance. Instance appears to be starting but stops after ~20 seconds.

Log file can be seen here:

[14:32:46] [Core Warning]         : Current time zone is set to MST - Servers should ideally be UTC to avoid time-zone related issues
[14:32:46] [Core Info]            : OS: Linux / aarch64
[14:32:46] [Core Info]            : CPU: ARM Cortex-A72 (4C/4T)
[14:32:46] [Core Info]            : AMP Instance ID: 8b8e71ec-1965-4cfa-a56d-1514d35baa78
[14:32:46] [ModuleLoader Info]    : Loaded MinecraftModule version by CubeCoders Limited
[14:32:46] [Minecraft Warning]    : Failed to get latest forge version data from
[14:32:46] [Core Error]           : WebException
[14:32:46] [Core Error]           : [0] (WebException) : An exception occurred during a WebClient request.
[14:32:46] [Core Error]           :   at MinecraftModule.UpdateManager.GetForgeUpdateData () 
[14:32:46] [Core Error]           : NotSupportedException
[14:32:46] [Core Error]           : [1] (NotSupportedException) : The URI prefix is not recognized.
[14:32:46] [Core Error]           :   at Net.WebRequest.Create (Uri requestUri, Boolean useUriBase) 
  at Net.WebRequest.Create (Uri requestUri) 
  at Net.WebClient.GetWebRequest (Uri address) 
  at Net.WebClient.DownloadStringAsync (Uri address, Object userToken) 
[14:32:46] [Core Info]            : Metrics publishing is enabled at udp://localhost:12820.
[14:32:46] [ModuleLoader Info]    : Loaded FileManagerPlugin version by CubeCoders Limited
[14:32:46] [ModuleLoader Info]    : Loaded EmailSenderPlugin version by CubeCoders Limited
[14:32:46] [ModuleLoader Info]    : Loaded WebRequestPlugin version by CubeCoders Limited
[14:32:46] [ModuleLoader Info]    : Loaded LocalFileBackupPlugin version by CubeCoders Limited
[14:32:46] [ModuleLoader Info]    : Loaded CommonCorePlugin version by CubeCoders Limited
[14:32:47] [FileManager Notice]   : No SSH keypair available for embedded server, generating new keypair...
[14:32:47] [FileManager Notice]   : Generated new keypair with fingerprint ZiqziAVk9abZQUbA9KmO5Rhe3FyK+DRGlPdsENZBd0U=
[14:32:47] [FileManager Notice]   : Using keypair with fingerprint ZiqziAVk9abZQUbA9KmO5Rhe3FyK+DRGlPdsENZBd0U=
[14:32:47] [FileManager Info]     : SFTP Server started on
[14:32:47] [Core Error]           : No valid AMP licence was found. Please run `ampinstmgr reactivate test` to reactivate this instance.

Actions taken to resolve so far:

-I made sure Amp as up to date. -I ensured Java was installed -I tried running ampinstmgr reactivate test as mentioned in the log.

None of these things seemed to help

I'm not sure what do to from here? Any suggestions?

Order By: Standard | Newest | Votes
Mike posted this 08 February 2021

Ah I forgot about this. AMP can't currently activate itself on the Pi. I will look into it.

soldemeyer posted this 16 February 2021

Thanks for taking a look at this! Is there anything I can do from my side to help try and resolve this?

Mike posted this 16 February 2021

Try the latest version. I changed a few things but I haven't tested yet.

soldemeyer posted this 16 February 2021

Still no luck. I get the same error.

jarrodthebobo posted this 18 February 2021

I'm currently having the same issue as well. I've tried pretty much everything but cannot get the server to authenticate

jarrodthebobo posted this 14 March 2021

Any new info?

soldemeyer posted this 16 March 2021

I'm also curious if there is any new info.

Mike posted this 17 March 2021

Not at the moment. Resources are spread a little thin right now so aarch64 support is on the back burner.

Nemos posted this 22 March 2021

Hi Mike, I have the same Issue. Is there a Way to start a minecraft Instances at the moment? Minecraft Server for the kids is the only reason for me to pay ure product...

nobi22 posted this 24 March 2021

Hi Mike, I have exact the same Problem.

It would be nice if you have a note somewhere that AMP does not work with Raspberry 4. For this reason, I see the purchase of the license as an incentive for you to repair it. So I hope that you will find a solution soon. It just seems to me that the license check doesn't work .... Is that such a big problem?

Mike posted this 24 March 2021

It's tricky because there's no particular reason why it should fail in the aarch64 build but not the x86_64 build. AMP has to be compiled for each specific platform since it's native code.

The problem is that it doesn't seem to be able to make any http or https requests, but it's proving tricky to track down. Despite replicating the build environments exactly the behaviour is different.

mbbneon posted this 28 March 2021

I came across an article with the title "mkbundle - Use of any Web/Http-Client causes "The URI prefix is not recognized." exception unless mono is installed"

It states that during the build the machine.config file has not been bundled with the package. @Mike, perhaps the solution in that article will solve this?

Quote from the article: "Thank you very much, that fixes it. Problem was solved by adding "--machine-config /etc/mono/4.5/machine.config" to the mkbundle command."

Mike posted this 28 March 2021

The compilation process has the machine config, same as the x86_64 builds. Which is why it's a tad confusing. I even tried manually building a new config.

I've got a little time today so I'll take another crack at it.

Mike posted this 28 March 2021

Just took a quick crack at it, delete your AMPCache files and see what happens when making new instances.

Nemos posted this 30 March 2021

Hi Mike

Thanks for your work. Which AMPCache files do you mean here exactly?

Mike posted this 30 March 2021


mbbneon posted this 31 March 2021

I have a few hours to spare today and will try it out.

--update-- I did a clean install of Ubuntu and AMP. Ik works now, I was able to create a Minecraft instance and start it. Great work Mike!

Mike posted this 31 March 2021

Eyyy, didn't need a machine config but it did need a new prefix list.

  • Liked by
  • Nemos
Nemos posted this 31 March 2021

Hi Mike,

I do the same thing. I did a clean brand new install of Ubuntu and amp and it’s Running faster then Usane Bolt :) I love your great work!!!!

soldemeyer posted this 31 March 2021

I also did a clean install of amp and it's working for me, too. Thanks a lot for the great support!