Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Minecraft Java server - add Geyser for Bedrock Clients

  • Last Post 08 July 2021
  • Topic Is Solved
speedyrazor posted this 06 July 2021

Hi, I have a Minecraft Java server setup, I have added the Geyser plugin (via AMP Plugin section), I added the custom ports in the instances (19132), restarted server, but can't seem to connect from IOS. Also I can curl to port 25565, but cannot curl to port 19132. is there anything else I need to do? Can someone point me in the direction of confining AMP with Geyser plugin please?

Order By: Standard | Newest | Votes
Mike posted this 06 July 2021

Are you using a Minecraft server type that supports Plugins such as Spigot?

speedyrazor posted this 07 July 2021

No, I am currently using 'default'. If I change to Spigot, will it delete / reset my current world?

AbhorrentJoel posted this 07 July 2021

It won't reset your world. Though if you have an existing world then before you change the server version it may be a good idea to make a backup.

Ensure you are using the right server version and plugin combination. From AMP, it installs the spigot version so you also need to use the spigot server type.

If you haven't read through this already, I'd highly recommend you do so.

speedyrazor posted this 07 July 2021

I read through the documentation. I still cant join the server from minecraft of my IOS device. If I create a new fresh Bedrock server, then Minecraft on IOS device connects fine, but will not connect to the Java edition with Spigot and the Geyser plugin installed. I think the issue is the 19132 UDP port, which I have added in the instances, but something somewhere is blocking connections. I am trying to connect from internal network to internal IP, so no port forwarding is required.

AbhorrentJoel posted this 07 July 2021

It looks like you should download directly from Jenkins and not through AMP itself. If you download Geyser through AMP, it appears to just download the html document and give it a jar extension - so of course, this won't work. If you had checked the console, you would have noticed an error saying it could not load the plugin. Since downloading directly and putting in the plugins directory, it appears to work fine.

  • Liked by
  • speedyrazor
speedyrazor posted this 08 July 2021

YES!!!! Thank you so much AbhorrentJoel, Once In stalled the Jenkins Geyser jar in the Plugins folder, restarted server, it just worked. Thank you so much.

AbhorrentJoel posted this 08 July 2021

Mike, if you see this, are you aware of any issues downloading Spigot plugins? In the case of Geyser, it just downloads the Jenkins page HTML and gives it a jar extension.