Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

minecraft module bad java arguments(missing space),also problem/solution for error with java 8/forge

  • Last Post 23 December 2017
korenchkin posted this 12 December 2017

hello, problem first:

from log: Unrecognized option: -server-XX:MaxPermSize=256m

from kvp conf: Java.CustomOpts=-XX:+UseConcMarkSweepGC -Dsun.rmi.dgc.server.gcInterval=2147483646 -XX:+UnlockExperimentalVMOptions -XX:MaxGCPauseMillis=100 -XX:UseSSE=3 -XX:ParallelGCThreads=3 -server

i think maxpermsize is obsoleted in java 8,just disable your params,or disable when user defined are present... i guess problem with space,it works on running server to edit and start,but after service restart it dies with error again on latest release and nightly tested right now

problem/solution two:

i can't find it anymore,but if anyone encounters this problem: 1.12(or 1.12.2?) forge server can't open minecraft_server.jar and stock recipes don't work(not sure what else),you need to run service under admin user(like john in group administrators),not networkservice,seems to be java 8 problem with some zip library and forge (all the mods 3 for 1.12.2 and direwolf 1.12 probably too)


Order By: Standard | Newest | Votes
Mike posted this 12 December 2017

First problem you can solve by changing the server type to Vanilla, for which AMP won't add any extra arguments.

The second issue is a permissions issue. AMP cannot (and will not) run as Admin, you need to make sure the NETWORK SERVICE user has full read/write access to all of the files in the Minecraft directory.

korenchkin posted this 12 December 2017

hello again, thanks for first problem,that helped,and as for second,it is permission issue,but different than you think,i was actually running it as admin and it worked,but as network service you need to go up,i have c:\programs\amp\minecraft... and i had netservice all access set on folder amp,BUT there really is a bug in 1.12(found the thread),we need(for now) privileges from \ (root),so i set it on 'programs' folder and down(no need from c drive,thank god) and problem is gone,i would recommend to stick this solution,since i found few threads unsolved with problem similar to this and there will be more like this till java 1.9

the solution shortened:for java 1.8 and minecraft 1.12 set network service access from highest folder on drive (c:\amp would probably worked out of box)

the thread about bug is here:

themooer1 posted this 23 December 2017

For the first problem, I've been adding a space to the end of the optional arguments, and it is working fine until I restart the instance and it removes the space. Is this going to be fixed / does there already exist a solution so there is a space when the two parts are concatenated?