Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

MinecraftModule instance creation issue

  • Last Post 10 January 2022
  • Topic Is Solved
Techno_Anomaly posted this 17 August 2018

System details:

  • OS/Version: Ubuntu 16.04.5 LTS
  • Product Name/Version: AMP Release "Hawking Starman" V1.6.9.0+(Including recent nightly)

Problem: I was having an issue with creating new Minecraft instances, both via ADS and cmd line. When attempting to login via web console no response and times out. Did a little digging in the logs and did not identify anything that was pointing it to a definitive issue. At that point I remove AMP from my system and upgraded from 14.04 ( why not do it now that I am having issues?). After the update same issue occurs. I eventually notice an error that is the following.

[14:09:33] [Core:System Error]    : Missing plugin/assembly: minecraftModule (/home/AMP/.ampdata/instances/creative/Plugins/minecraftModule/minecraftModule.dll) [14:09:33] [ModuleLoader:System Error] : Unable to load module minecraftModule: Could not load file or assembly 'minecraftModule' or one of its dependencies

it appears that during the setup of the instance it is looking for "minecraftModule/minecraftModule.dll" but Linux is case sensitive and the directory and file are "MinecraftModule/MinecraftModule.dll". I was able to resolve the issue by changing the name of the directory and the file to correlate with what AMP was looking for within both the, and files . This solved my issue and I was able to start the instance and login with no issues. I was not able to identify exactly what was calling the Module, so I can not test from there with the fix. I hope this helps to fix this minor inconvenience.

Order By: Standard | Newest | Votes
Mike posted this 17 August 2018

The filename/module name is wrong. It should be MinecraftModule not minecraftModule (case-sensitive).

Techno_Anomaly posted this 17 August 2018

New issue to add on to this, after a reseting the instance this error is occurred and now due to my fix it will not work. [Error] [0] (FileNotFoundException) : Could not find file "/home/AMP/.ampdata/instances/creative/Plugins/MinecraftModule/WebRoot/Skins/Steve.png".

As you can see it is looking for "MinecraftModule" where I changed that directory to be "minecraftModule" to fix the previous issue.

I have created duplicate directories with the various capitalization methods, and it is ugly but working, for now.

Techno_Anomaly posted this 17 August 2018

Agreed, I am assuming AMP_Linux_x86_64 is calling the lowercase version on initial setup when it should in fact be capitalized. I have searched through all of the scripts and other various files to see if I can identify what is calling it incorrectly but I cannot, which as I said leads me to believe that AMP_Linux_x86_64 is what is calling it improperly.

Mike posted this 17 August 2018

The module name is defined in AMPConfig.conf

Techno_Anomaly posted this 17 August 2018

Ok thanks, I must have missed that.

lordnex posted this 04 January 2022

Was there a resolution to this issue? I'm getting the same error trying to create new instances. I was able to create one Minecraft instance, but trying to add another does the above for me.

lordnex posted this 04 January 2022

Ok I deleted the instance and created a new one. Checked the console and this is the output

03:30:46 su: ignoring --preserve-environment, it's mutually exclusive with --login -bash: line 1: /AMP/AMPLinuxx86_64: No such file or directory 03:31:01 Returned exception from API call FileManagerPlugin/GetDirectoryListing NullReferenceException [0] (NullReferenceException) : Object reference not set to an instance of an object at FileManagerPlugin.WebMethods.GetDirectoryListing (String Dir) at GSMyAdmin.WebServer.WebAttributes.InvokeMethod (String MethodName, Newtonsoft.Json.Linq.JObject Data, m.Http.IHttpRequest request, ModuleShared.IWebSession Session, ModuleShared.WebMethodsBase MethodsClass, String RawRequest) at GSMyAdmin.WebServer.APIService.InvokeAPI (m.Http.IHttpRequest request, ModuleShared.IWebSession Session, Newtonsoft.Json.Linq.JObject Data, String RequestModule, String RequestMethod, String RawRequest)

lordnex posted this 04 January 2022

Think I fixed it. I did a sync-certificates and after that everything seemed to install ok. Go figure?

leitchy posted this 10 January 2022

Could you give a little more info on what you did, I'm having what I think is the same issue. thanks