Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

More problems with L4D2 (srcds) instances

  • Last Post 14 July 2020
  • Topic Is Solved
Veltys posted this 13 July 2020

Hello everyone!

I need to move an instance from one Windows server to another, since the first one will first be closed, but I have some troubles with a L4D2 (srcds) instance.

OS Name/Version:

Windows Server 2019 1809

Product Name/Version:

AMP Release "Europa" v2.0, built 10/07/2020 21:34

Problem Description:

After a successful installation and download... the instance cannot start the srcds server. To rule out configuration issues, I have tried to start a "clean" (unconfigured) installation, with the same result.

Steps to reproduce:

  • Installing an instance
  • Configure
  • Launch
  • CPU peak and crash

Actions taken to resolve so far:

  • Clean installation.
  • Checking AMP verbose (Monitoring.LogLevel=0) logs.
  • Checking L4D2 logs.
  • Starting server without AMP.

Sadly, logs are not descriptive at all.

AMP instance log only says "Application state changed from Starting to Stopped":

[04:12:48] [Core Warning]         : Current time zone is set to Hora estándar romance - Servers should ideally be UTC to avoid time-zone related issues
[04:12:48] [Core Info]            : OS: Windows / x86_64
[04:12:48] [Core Info]            : CPU: Intel(R) Celeron(R) CPU G1610T @ 2.30GHz (2C/2T)
[04:12:48] [Core Info]            : AMP Instance ID: bf5f963d-6412-4bd7-a7d1-16ad3d96dcb8
[04:12:49] [Core Debug]           : Using remote login server [URL of the server]
[04:12:49] [ModuleLoader Info]    : Loaded srcdsModule version by CubeCoders Limited
[04:12:49] [ModuleLoader Info]    : Loaded FileManagerPlugin version by CubeCoders Limited
[04:12:49] [ModuleLoader Info]    : Loaded EmailSenderPlugin version by CubeCoders Limited
[04:12:49] [ModuleLoader Info]    : Loaded WebRequestPlugin version by CubeCoders Limited
[04:12:49] [FileBackup Debug]     : Read manifests for 0 backups.
[04:12:49] [ModuleLoader Info]    : Loaded LocalFileBackupPlugin version by CubeCoders Limited
[04:12:49] [ModuleLoader Info]    : Loaded CommonCorePlugin version by CubeCoders Limited
[04:12:49] [ModuleLoader Info]    : srcdsModule requests dependency steamcmdplugin...
[04:12:49] [ModuleLoader Info]    : Loaded steamcmdplugin version by CubeCoders Limited
[04:12:49] [ModuleLoader Info]    : srcdsModule requests dependency RCONPlugin...
[04:12:49] [ModuleLoader Info]    : Loaded RCONPlugin version by CubeCoders Limited
[04:12:50] [Core Info]            : Licence Present: AMP Professional Edition (Licenced to [Me])
[04:12:50] [WebServer Debug]      : Using webroot: E:\AMPDatastore\Instances\srcds01\WebRoot
[04:12:50] [WebServer Info]       : Websockets are enabled.
[04:12:50] [APIService Debug]     : Building setting specification cache...
[04:12:50] [APIService Debug]     : Setting spec cache built, 83 items added.
[04:12:50] [WebServer Warning]    : RouterTimer@10Hz with 2 jobs started
[04:12:50] [WebServer Info]       : Webserver started on
[04:12:50] [Core Debug]           : Scheduler timer will start in 9615ms.
[04:12:50] [Core Info]            : Checking for AMP updates...
[04:12:50] [System Debug]         : Successfully got update data.
[04:12:50] [Core Info]            : AMP is up-to-date.
[04:13:08] [System:Anonymous Debug] : Login request from session eb8aedb2-ebe2-4c6b-8660-0978080039da
[04:13:08] [Core:Anonymous Activity] : Authentication attempt for user Veltys from
[04:13:08] [Core:Anonymous Debug] : Logging in via remote auth server [URL of the server]...
[04:13:09] [Core:Anonymous Activity] : Authentication success
[04:13:15] [System:Veltys Activity] : Starting the application.
[04:13:15] [srcds:Veltys Debug]   : Application state changed from Stopped to PreStart
[04:13:15] [srcds:Veltys Debug]   : UDP logger listener started on
[04:13:15] [srcds:Veltys Debug]   : Starting process E:\AMPDatastore\Instances\srcds01\srcds\222860\srcds.exe
[04:13:15] [srcds:Veltys Debug]   : Working Directory: ./srcds/222860
[04:13:15] [srcds:Veltys Debug]   : Arguments: -game "left4dead2" -console -usercon -ip "" -port "27015" +rcon_password "7e6a105e16f248668fc5897cfdef7138" +map "c1m1_hotel" +maxplayers "8" +hostname "Plus L4D2 Server" +sv_password "" +sv_pure "WhiteListed_Content" +sv_contact "[my email]" +sv_steamgroup "35380402" +sv_steamgroup_exclusive "1" +motd_enabled "0" +sv_allow_lobby_connect_only "1" +sv_voiceenable "0" +sm_cvar "survivor_friendly_fire_factor_easy 0" +log "on" +logaddress_add "" +sv_setsteamaccount "BA337D2AD2A44AB142CD96F2B10C7BB2"
[04:13:16] [srcds:Veltys Debug]   : Started process with ID 3448
[04:13:16] [srcds:Veltys Debug]   : Application state changed from PreStart to Starting
[04:13:17] [srcds:Veltys Debug]   : Application state changed from Starting to Stopped

l4d2 logs are, simply, empty.

As I said before, I started the server by itself, just opening PowerShell and pasting executable path and same parameters AMP say are using... result? Success! The server now runs by itself. So I think it would be a problem with AMP. Maybe a security permissions problem? I followed tips and warnings given on "Install instructions for Windows" section.

I don't know what else to do to fix it, so I ask for your help.

Thank you in advance.

Order By: Standard | Newest | Votes
Mike posted this 14 July 2020

Srcds is just fickle, I'm not really sure what to do about it.

Veltys posted this 13 July 2020

Hello again!

Thanks, Mike, running as AMP user and not as a service works fine 😁

Is it possible to do something to fix it? I mean, in the old server (Windows too, 2016) it works fine in any case. Why now it doesn't run? Permissions issues maybe?

Mike posted this 13 July 2020

Srcds doesn't always like running as a service on Windows. Try setting up ADS to not be a service then make a new instance.