Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

New Factorio instance won't start

  • Last Post 28 April 2020
  • Topic Is Solved
INGY posted this 18 April 2020

This used to work before November but both an existing and a new factorio instance wont start.

OS: Ubuntu 18.04.4 LTS

AMP: v1.9.8.6

Error: Error Util.cpp:83: Error configuring paths: There is no package core in /home/amp/.ampdata/instances/Factorio02/factorio/bin/x64/data. Deduced executable directory: /home/amp/.ampdata/instances/Factorio02/factorio/bin/x64, read data: PATHexecutable/data, write data: _PATHexecutable_/data

Order By: Standard | Newest | Votes
INGY posted this 18 April 2020

Ok I have managed to get the server to start by copying the data folder to factorio/bin/x64

So it looks like the issue is with config.ini that has the paths

[path] read-data=PATHexecutable/data write-data=PATHexecutable/data

I have tried changing these but the server replaces these when I start it.

Mike posted this 18 April 2020

The Nightly build of AMP has a fix for this. Either swap that instance over to Nightly or wait for the next update (coming Monday) :)

mattygroch posted this 27 April 2020

Looks like I'm still getting this error on a new Factorio instance. When I switch it to a Nightly, the management for the instance is inaccessible. Is there a timeline on a fix?

Mike posted this 27 April 2020

A new update should be shipping this week which has the fix from Nightly in the main release.

mattygroch posted this 28 April 2020 seems to have cleared everything up. Thank you!