Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

New installation and getting an error when attempting to add users to whitelist

  • Last Post 11 August 2017
  • Topic Is Solved
fumitol posted this 10 August 2017

OS Name/Version: Ubuntu 16.04

Product Name/Version: MCMA 3 / AMP

Problem Description: I've taken the plunge and have decided to learn how to do this all on my own without someone setting it up for me. I've gotten MCMA installed and it loads fine, but when I attempt to add a JAR (Forge for example), It keeps presenting the EULA and loading Forge in the bottom right of the screen.

I have just gone and tried to add someone to the Whitelist and I receive the following error:


Unable to get user information for whitelist addition Parameter name: UserOrUUID

Thrown by the 'MinecraftModule' plugin while performing the 'AddToWhitelist' method.

I have an inkling that the two issues are somehow related and that I have fudged something during the installation. Sadly, I am not quite sure what I have done here.

Steps to reproduce:

  1. Install MCMA onto ubuntu 16.04
  2. Attempt to add someone to the server

Actions taken to resolve so far: I have gone and reformatted the entire server (It's only for this and a small forum for users) and went step by step (Adding ports to ufw and making sure that AMP was non-sudo-ed)

Order By: Standard | Newest | Votes
Mike posted this 11 August 2017

Known issue, the functionality needs re-implementing.

  • Liked by
  • fumitol
fumitol posted this 11 August 2017

Thanks Mike! I'll hand jam them in for now.

Also, figured out why the JARs wouldn't load. I was a moron and hadn't installed Java :/. It's always the simple things.

Thanks again!