Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

New super admin users not able to see instances that were created before their accounts existed

  • Last Post 18 July 2020
failedsquare posted this 06 July 2020

System info:
OS Linux
Platform Ubuntu 18.04.4 LTS
System Type x86_64
Virtualization VMware
Module ADSModule
Loaded Plugins FileManagerPlugin, EmailSenderPlugin, WebRequestPlugin, LocalFileBackupPlugin, CommonCorePlugin
Application Name AMP
Application Version
Release Stream Release
Build Date 23/06/2020 23:18
InstanceID *Redacted - Available on request*
Last Executable /bin/readlink
Last Arguments -s -f -n "/home/amp/.ampdata/instances/Minecraft02"

Newly created users in “Super Admins” role cannot see instances that were created prior to their user account.

Steps to reproduce:
1: Fresh install of AMP using tutorial
2: Complete setup and create the main user account using the “ampinstmgr quickstart” command in the tutorial and enable the ampinstmgr service.
3: Create a new instance for 7 days to die game server.
4: Create a new user through the GUI and add the “Super Admin” role to the user profile.
5: Log in using the new account and attempt to view current instances on the server. They are missing for the new user.

Actions thus-far:
-Created multiple new user accounts which all showed the same behavior.
-Created a new role with all permissions enabled and added new users to that role.
-Create a new instance from my account (the first user created during the cli setup outlined in the tutorial). The new instance shows up for the new users. Tried other applications ie. Minecraft, factorio
-Create a new instance from the new account (the user created through the web GUI). The new instance shows up for the new user and my account. Tried other applications ie. Minecraft, factorio
-Stop and restart all instances.
-Purge browser cache
-log into gui using the servers ip address instead of hostname.domain
-Try different browser
-Reboot server
-Ask the same question in the discord #tech support channel

Note: The server is accessible on the web. I can provide access to cubecoders support
Also there are no problems with the instances themselves as they seem to work fine. They just arent visible to new users.

Order By: Standard | Newest | Votes
failedsquare posted this 13 July 2020

Really disappointment with the support for this product.
I was ignored in discord and on the support forums. As far as I can see I met all the criteria for submitting a question in this post.

Mike posted this 14 July 2020

Sorry this post got lost under everything else.

Does this still occur in 2.0? And does it persist after restarting ADS?

failedsquare posted this 18 July 2020

I dont know if the update fixed it. I decided to delete the instances and recreate them (which was a work around I found trying to troubleshoot). Restarting the service or the server itself had no effect. The upgrade seems to work okay. But as for the problem I described I cant say if it was fixed in the update or not.