Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Satisfactory Failure Error: "The application stopped unexpectedly"

  • 130 Views
  • Last Post 09 December 2021
pdxampuser posted this 08 December 2021

Os Version: Windows 10 PRO (build 19043.1348)

Cube Coders Product: Amp v2.3.0.6

Module Used: Satisfactory [G]

Issue: After installing the Satisfactory server successfully, I am unable to start Satisfactory due to an unexpected error (see error log and screenshot)

Steps to Reproduce:

  1. Create a new Satisfactory amp instance
  2. Mange the server and click "update" to install Satisfactory
  3. Start the Satisfactory server
  4. Expected: The server should start
  5. Actual: The server fails to start and the instance crashes to where I need to restart the instance

AMP Instance Logs:
Update state (0x81) verifying update, progress: 87.92 (7752856209 / 8818484097)
Update state (0x81) verifying update, progress: 96.02 (8467561751 / 8818484097)
Success! App '1690800' fully installed.
[20:54:03] [API:admin Activity]   : Starting the application.
[20:54:03] [System:admin Warning] : The application stopped unexpectedly. Exit code -1073741515
[20:54:03] [System:admin Warning] : The application stopped unexpectedly. Exit code -1073741515
[20:54:03] [System:admin Warning] : The application stopped unexpectedly. Exit code -1073741515
[20:54:03] [System:admin Warning] : The application stopped unexpectedly. Exit code -1073741515
[20:54:03] [System:admin Warning] : The application stopped unexpectedly. Exit code -1073741515
[20:54:03] [System:admin Warning] : Application failed to start 5 times, not restarting.

Screenshot:

https://i.ibb.co/BctkxW3/amp-screen-shot.jpg

Steps Tried to Resolve:

  • Watched the "Creating a Satisfactory server the easy way using AMP" YouTube video

  • Tried deleting and recreating a new Satisfactory instance

  • Tried to find the Satisfactory server logs for clues, but couldn't

  • Made sure the Satisfactory server port does not conflict with other AMP instances

Order By: Standard | Newest | Votes
Mike posted this 08 December 2021

Install .Net Framework 3.5

pdxampuser posted this 08 December 2021

Hey Mike,

Thanks for the tip. I only have 4.0 installed. I'll go ahead and install 3.5 and see if that clears things up. I actually wondered if this might be a framework issue. So, searched a few websites looking for dedicated server requirements, but I couldn't find any mention of what version of .NET framework you need (see below). Oh well... I guess it's still "experimental".

https://questions.satisfactorygame.com/search?category=dedicated%20servers https://satisfactory.fandom.com/wiki/Dedicatedservers

Thanks again!

pdxampuser posted this 09 December 2021

Hey Mike,

Well.... Installing .NET 3.5 didn't help. So, I tried to launch the Satisfactory dedicated server via command-line (.\FactoryServer.exe -log -unattended) to see what else could be preventing it from starting up. As soon as I ran the command I was prompted to install DirectX (see screenshot).

DirectX Prompt Screenshot: https://i.ibb.co/VB4hSLp/DirectX.jpg
DirectX Download: https://www.microsoft.com/en-us/download/details.aspx?id=35

After installing DirectX I was able to get the server running, but I couldn't establish a connection. It just showed as "offline" and I couldn't "claim" it like your video showed. After looking at the Satisfactory logs a bit, I noticed that the ports that were configured by default in the Satisfactory instance don't match what the game client is looking for. I had to edit the instance ports to the following to get the game to connect.

Application Port 1= 7777
Application Port 2 = 15000
Application Port 3 = 15777

Well, I'm up and running now. I just thought I would report back in case anyone else had similar troubles.

Thanks !

Close