Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Scheduler partially not working

  • 142 Views
  • Last Post 23 October 2020
Kirschi posted this 22 October 2020

OS Name/Version: Windows 10 Pro, Version 2004 (Build 19041.572)

Product Name/Version: AMP Release "Europa" v2.0.7, built 19/10/2020 15:35

Problem Description: The advanced interval somehow seems to only partially recognize the input I'm giving. I selected the necessary boxes to tell it to restart the server at 6 am but it somehow restarts every hour. It can't be any other task, as these either involve sending an E-Mail to me (and I didn't get any) or don't involve restarting the server.

The log repeats the following for every hour:

[XX:00:00] [System Info]          : Application stop requested

I've not been able to play around with it a lot, but I wouldn't know what to try either to be honest.

Actions taken to resolve so far:

  • Edited the trigger multiple times to match only restarting at 6 am

  • Completely deleted and recreated the trigger with the correct inputs

  • Restarted the Minecraft-Module and the ADS-Module both separately and collectively

  • Installed and uninstalled the Minecraft-Module and the ADS-Module as service both separately and collectively (caused other problems which I was fortunately able to fix by killing the AMP Core process)

Kirschi posted this 23 October 2020

Some new information:

I've reinstalled pretty much everything on a separate user and will find out if that fixed the problem. Meanwhile I've found some information in the logs that might help find the cause of the problem:

[13:22:11] [Core Warning]         : Schedule trigger e263420d-992a-49cf-a499-ff955498a427 has a mismatched ID!
[13:22:11] [Core Warning]         : Schedule trigger 2699fd8a-d545-4845-87b7-03c7faf5b140 has a mismatched ID!

Log says this everytime the Minecraft-Server Instance is started, even after reinstalling everything this is still present. Before reinstalling it were 4 warnings, now they're down to two.

Update:

The restarts now don't happen every hour, so the main problem is solved. Only the question what won't work because of the mismatched IDs of these two triggers remains.

Close