-The OS you're using and its version: Windows 10 Pro 64bit

-The name and version of the Cubecoders product you are using. Make sure to specify the actual version, and -not just that it's the 'latest' version: AMP release v2.3.1

-A description of the issue you are having: I am having an issue with leaving my server running overnight or for long periods of time with no one active on it. I have the paper server running 24/7 with sleep rules active and for the server to restart when someone pings the server. This works great when the server has not been running for long periods of time and people have been able to wake the server and connect properly. However sometimes when the server has been running for a long period of time with inactivity i will get the error bellow

WARN19:23:45 ** FAILED TO BIND TO PORT! The exception was: java.net.BindException: Address already in use: bind Perhaps a server is already running on that port?

I do have another bedrock edition server running but it is running on the port 19150 and 19151 while this server is being run on port 25570... the server connects and works fine until a long period of inactivity. I have a seperate server PC running the same Windows 10 that AMP is hosted on that is kept on at all times. My bedrock server does not seem to suffer from the same issue ever. Both servers also have automatic backup and restart every 8 hours, both do these scheduled events at different times of the day as well.

-Steps to reproduce the issue (for bugs in particular): Leaving the server on for long periods of time with no one joining.

-What you have tried so far to resolve the issue and what happened.: I have tried reinstalling several times, reinstalling AMP several times, and etc.. I have not tried running the server on a different port as I see no reason to do so but would be willing to give it a try. All the correct ports I need forwarded are forwarded.

-A paste of any relevant output from the log file for a given AMP instance (where applicable).:

Console19:23:37 Starting org.bukkit.craftbukkit.Main System Info: Java 17 (Java HotSpot(TM) 64-Bit Server VM 17.0.1+12-LTS-39) Host: Windows 10 10.0 (amd64) Loading libraries, please wait... INFO19:23:42 Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD' Reloading ResourceManager: Default, bukkit 19:23:43 Loaded 7 recipes 19:23:44 Starting minecraft server version 1.18.1 Loading properties This server is running Paper version git-Paper-152 (MC: 1.18.1) (Implementing API version 1.18.1-R0.1-SNAPSHOT) (Git: 78999b5) 19:23:45 Server Ping Player Sample Count: 12 Using 4 threads for Netty based IO Default game type: SURVIVAL Generating keypair Starting Minecraft server on Using default channel type Paper: Using Java 11 compression from Velocity. Paper: Using Java cipher from Velocity. WARN19:23:45 ** FAILED TO BIND TO PORT! The exception was: java.net.BindException: Address already in use: bind Perhaps a server is already running on that port? INFO19:23:45 Stopping server Saving players Saving worlds ThreadedAnvilChunkStorage: All dimensions are saved Flushing Chunk IO Closing Thread Pool Closing Server

This will repeat in the console continuously until AMP told me the server is unable to be restarted due to constant errors.

-For AMP, which application module you're using.: Minecraft java edition.. however it is running paper with only 2 plugins

NOTES If you need me to state anything else please let me know, I have been at this for some time now trying to fix it and still nothing. I do not want to give up automatic backups, restarting, or sleep mode as those are important to me. Starting and Stopping the instance seems to do the trick for now.