Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Sleeping not supported with Forge server type

  • Last Post 18 May 2018
Akaitatsu posted this 18 May 2018

OS Name/Version: Windows Server 2012 R2

Product Name/Version:

  • AMP/
  • Minecraft module/
  • Forge 1.12.2- (installed by AMP)

Problem Description:

The Status screen shows a Sleep button but when I click it I get this:

Not Supported
Sleeping is not supported by the current Minecraft server type.
Thrown by the 'Core' plugin while performing the 'Sleep' method.
Related Link: Get help for this issue

The following entries are in the AMP logs.

[13:05:19] [GSMyAdmin:Admin Warning] : Returned exception from API call
[13:05:19] [Core:Admin Error]     : [0] (NotSupportedException) : System.NotSupportedException: Sleeping is not supported by the current Minecraft server type.
   at MinecraftModule.MinecraftApp.Sleep()
   at GSMyAdmin.WebServer.WebMethods.Sleep()

If Sleep is truly not supported with a Forge server then I expect the button to be disabled with a tool-tip that explains why it's not available.

I'm not sure why it's not supported. I "converted" the FTB Revelation modpack that I was using before to a Forge modpack so I could update some of the mods. Sleep worked fine with FTB Revelation. Is this something that was broken in a more recent version of Forge?

Steps to reproduce: Sorry, I can't provide much here as I didn't take good notes as I was making changes. Here is what I did recently:

  1. I had been running FTB Revelation on an older version of AMP (1.5.something I think) for a while but there was a bug in a mod that I wanted to fix. This required a new version of the mod which, in turn, required a Forge update. This broke the modpack so I "converted" the FTB pack to a custom pack with MultiMC.
  2. To get the custom pack on the server, I changed the server configuration to Forge instead of FTB and let AMP download the pieces for the version I selected (see above). That worked fine but I was getting the issue where AMP reports that the server is starting forever but it is actually running.
  3. Updated AMP to 1.6.8. That fixed the continuous Starting issue but now I have the Sleep Not Supported issue instead.

Actions taken to resolve so far: Google, but didn't find anything.

Mike posted this 18 May 2018

This is by Design. Only Server types that can be connected to with the official client are supported by sleep mode and AMP doesn't know if it's going to work until it tries.

So what's actually going on is AMP tries to set up sleep mode, and disables it if it fails. The server type setting doesn't actually mean a right lot so its not a good way to determine if sleep is available or not.