Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Space Engineers Module Probably Broken

  • Last Post 01 December 2020
Captain Sopressa posted this 30 November 2020

  • OS: Windows 10

Starting a Space Engineers Vanilla server IN SURVIVAL with no issues, game client connect easily at it. Once connected:

  • i wasn't able to get rock/ores while mining (in this case with hand drill).
  • The suit resources like H2/O2 and Energy are infinite in Survival.
  • It starts in "Experimental Mode" regardless the setting.

So, i've tried any type of combination to solve this "bug"

  • Delete,Recreate the istance and re-download the server [Not Resolving]
  • Delete the world and restart the server [Not Resolving]
  • Tried to change SpaceEngineers-Dedicated.cfg, both deleting and not the worldsave before, and reloaded the server [Not Resolving]
  • Tried to change directly the World's SpaceEngineers-Dedicated.cfg [Not Resolving]

At this point i've tried the standalone server from Steam It boots up and works fine. I think some app config in SE module is kinda obsolete for the current version of SE.

I've solved the issues in this way:

  • Boot up the official server tool from steam, start new worldsave and choose preferred settings
  • go to %appdata% SE folder copy the whole directory to the AMP Server worldsave directory
  • The SpaceEngineers-Dedicated.cfg will prob get rewrited due to AMP settings, but the server now will read the world's settings file, which now is generated by official server tool.

Finally i got the server work at 100% on my AMP Istance.(At least for the first boot, i hope won't broke again if i stop or reboot the istance).

  • H2/O2/Energy decreasing while using the suit.
  • Ores and Rocks dropping normally
  • No Forced Experimental mode

I think is a AMP SEModule issue. If any developer can confirm or deny it I would like to know if what I have found is correct.

I hope this thread could help someone in trouble and the module(if that's the problem) gets an update.

Have a nice day!

Captain Sopressa

(I apologize for my english in case of mistakes, i'm from Italy :D)

Order By: Standard | Newest | Votes
Mike posted this 30 November 2020

Try loading up the config file AMP generates and comparing it to an official config.

Captain Sopressa posted this 01 December 2020

This settings for example comes from the world's settings file generated by original dedicated server launcher, which is missing from AMP settings panel:


AMP-Generated file reports the value "1" instead of "4". I don't find any settings into the AMP management panel about this parameter.

I mean, maybe this particular settings doesn't mean nothing but certainly there are some differences(Probably wrong settings for default server profile in AMP?).

The server now with the world imported from the developer server app works fine in AMP too.