Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Space Engineers server refuses to start

  • Last Post 24 November 2020
  • Topic Is Solved
Veltys posted this 23 November 2020

Hello everyone,

I am having a problem with a Space Engineers server. Let me proceed to comment what is happening.

OS Name/Version: Microsoft Windows Server 2019 Standard

Product Name/Version: AMP Release "Europa" v2.0.8.2

Module: SpaceEngineersModule

Problem Description: On a fresh install, Space Engineers server refuses to start with "Cannot start new world - Premade world not found" fail. Also, as I saw in log, Server seems to ignore (at least) some parameters.

AMP Log: Too long message, uploaded to

Steps to reproduce:
- Add a new Space Engineers instance
- Configure and start such instance
- Manage instance
- Update and finish configuration
- Try to start server

Actions taken to resolve so far:
- Try to start the server with a valid save file from other functional server. - Searched on Internet the error. - Looked for a similar problem here.

Additional comments:
As log says, server is trying to binding itself to the port 27016, however... I previously configured AMP instance port to 27026, because 27016 is binded to other server (ARK server, works fine, nice job 👍🏼). So, I am thinking... is it possible server is ignoring AMP configuration and just trying to start with default parameters? Maybe it could be the reason that explain why the server is telling me "Premade world not found".

Researching a bit on Keen Software House forums, I have come to the conclusion that server only looks for Premade world when save game is not found... which is the right behaviour when I am not using a save world... but I am getting the same error when I am using a save world, which indicates to me one more time server is having troubles to load configuration file (you know: first, wrong port binding; now, that).

Thank you so much for your help!

Order By: Standard | Newest | Votes
Mike posted this 23 November 2020

SE is trying to start its API on port 8080 which AMP is using, AMP doesn't currently know about that port to make sure it's re-assigned. A fix for this is due soon.

  • Liked by
  • Veltys
Veltys posted this 24 November 2020

Thank you, Mike, for your quick reply. Last update fixed everything! 😁