Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

{RESOLVED}Startup failure: Docker returned error code 125

  • 157 Views
  • Last Post 31 December 2021
  • Topic Is Solved
lordnex posted this 30 December 2021

Fresh install of Ubuntu Server LTS 20.04.3, selected Docker during Ubuntu install. The install of AMP pretty much went fine and is up and running, but when I try and create the first instance which is Minecraft Java Edition I get the Startup failure: Docker returned error code 125

Unsure where to go from here except disabling AMPs usage of Docker. Any better solutions guys? And thanks in advance!

Order By: Standard | Newest | Votes
Mike posted this 30 December 2021

What environment is AMP running in? Is it in a virtual machine of any kind?

lordnex posted this 31 December 2021

Yes, I'm running VMWare ESXi 7 as the main hypervisor. Then a VM of Ubuntu Server 20.04.3 LTS.

If I shut off docker and create an instance, it appears to create. But clicking manages either leads to an Instance not running error. Or a constant loading screen you see before the actual management tools page shows up.

Again this was a fresh install with just the security patches installed.

I followed the advanced install from the wiki https://cubecoders.com/AMPInstall

I finally received my new license key and plugged that in. I still get an error under docker but if I leave that unchecked I can start the instance, and manage the instance. but it's not showing any resources being used, of course, is now ones in yet, and it's saying "Application State: Installing components"

So I'm somewhat hopeful. I also noticed that under the Java area it says not installed. Now I didn't manually install Java because the install didn't say to. It basically said everything needed would be installed automatically. So do I need to manually download and install Java?

lordnex posted this 31 December 2021

More info

amp@powmc01:~$ ampinstmgr start POWMinecraft

[Info] AMP Instance Manager v2.3.0.8 built 21/12/2021 15:40 [Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV [Info] Starting Instance: 'POWMinecraft' [Info] 13e4a6864825322968cfee600192cec2273852661a979b0866e6240f0a1c981c [Info] docker: Error response from daemon: driver failed programming external connectivity on endpoint AMP_POWMinecraft (f33763b574f625c683f6fa06b736a042e5b28428f569f90f833da9e6561c034e): Error starting userland proxy: listen tcp4 0.0.0.0:8081: bind: address already in use. [Info] This instance failed to start. Run 'ampinstmgr LastLog POWMinecraft' to view it's most recent log.

Mike posted this 31 December 2021

Looks like docker isn't running properly. Try service docker restart as root.

Java is only required to run Minecraft instances. You can install it after the fact by running:

bash <(wget -qO- getamp.sh) installJava

Also make sure that AMPs default port ranges aren't in use by other applications (Configuration -> Networking) Otherwise I'd suggest rebooting the host.

lordnex posted this 31 December 2021

Restarting the server didn't solve the issue. neither did restart docker. Right now I just want to get Minecraft going. I tried several installs of Java and all come back with this error

Error: LinkageError occurred while loading main class net.minecraft.bundler.Main

java.lang.UnsupportedClassVersionError: net/minecraft/bundler/Main has been compiled by a more recent version of the Java Runtime (class file version 61.0), this version of the Java Runtime only recognizes class file versions up to 55.0

When I try to run

Installation Summary:

AMP System user: Already exists Instance Manager: Already installed HTTPS setup: Yes, via nginx with domain powersofwar.duckdns.org Install Java: Yes Install 32-bit libraries: Yes Install Docker: Yes

Ready to install AMP. Press ENTER to continue or CTRL+C to cancel.

Installing AMP... amp already exists. Skipping... amp already has instances. AMP appears to be already installed and configured. Aborting...

Mike posted this 31 December 2021

Don't put sudo in front of the command. Run it separately (sudo su) then run the command I gave verbatim.

lordnex posted this 31 December 2021

ok, I also found out that docker-ce didn't get installed by the ubuntu install so installing that got me further. I then did as you said and were now at

lordnex@powmc01:~$ sudo su [sudo] password for lordnex: root@powmc01:/home/lordnex# bash <(wget -qo-="" getamp.sh)="" installjava=""> Please wait while GetAMP examines your system... Installing Java for Minecraft...

lordnex posted this 31 December 2021

Ok I got further. It finished its install so I changed the options to use docker and rebooted the server. When it came back up I cant seem to get back to the managment interface. I reran through

Installation Summary:

AMP System user: Already exists Instance Manager:
Already installed HTTPS setup: Yes, via nginx with domain powersofwar.duckdns.org Install Java: Yes Install 32-bit libraries: Yes Install Docker:
Yes

Ready to install AMP. Press ENTER to continue or CTRL+C to cancel.

Installing AMP... amp already exists. Skipping... amp already has instances. AMP appears to be already installed and configured. Aborting...

lordnex posted this 31 December 2021

Why does the preview show it looking good and then I click post and it all gets messed up

lordnex posted this 31 December 2021

Accidently marked as resolved. it is not. I have the instance running but it says Application State: Installing components

and doesn't seem to do anything else. I don't see any major activity from the VM so I dont know if i just need to wait or if theres a problem

lordnex posted this 31 December 2021

Finally worked it out. thanks for the help. I have questions but ill post separately if i cant already find the answer out there

Thanks again!!

Close