Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

SteamCMD password with special characters

  • Last Post 29 September 2021
krizzyb posted this 29 September 2021

Hey guys,

I noticed if you try to login with SteamCMD to create an Arma III instance (for example) and your password has certain special characters such as '{' and '}' this can cause an issue somewhere in the process.

I tried to login to a steam account with a password in the format: '{password123}' and it would always report incorrect password from SteamCMD. I was able to login to SteamCMD via command prompt with the password but not in AMP, leading me to believe that the issue must be somewhere in the application. It is likely the password is incorrectly parsed due to the use of the curly brases. I updated the password to use a different format and it worked fine in AMP.

I understand this is an extreme edge case but could effect other passwords that use special characters that are valid by Steam's standards. Might be worth looking at.


Mike posted this 29 September 2021

Might be necessary for us to add the curly braces to the list of characters to escape. Steamcmd can behave a little weird on Linux sometimes with special characters