Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Terraria fails to update after creating instance

  • Last Post 02 November 2021
  • Topic Is Solved
cmdr_scotty posted this 29 October 2021

Running AMP on Ubuntu 20.04 AMP v 2.3

I created an instance of Terraria and after going to manage it, I get the login prompt for SteamCMD.

After providing the credentials, it'll start by saying it's installing the components, then go to a perpetual 'Updating...' cycle while also saying:

Application State: Unable to run.

Nothing in the console either. If there's a location where it's logging errors, where would that be (rather new to AMP).

Would like to figure out what's causing it to fail so i can get it to build and launch properly.

Edit: it's not letting me post a reply with images, so adding them here:

enter image description here

enter image description here

Order By: Standard | Newest | Votes
cmdr_scotty posted this 29 October 2021

So managed to find the log file for the instance (hidden folder :p )

This is what it's outputting for trying to use SteamCMD

[16:27:41] [Core Info]            : AMP is up-to-date.
[16:27:47] [RemoteAMPAuth:Anonymous Activity] : Authentication attempt for user admin from
[16:27:48] [RemoteAMPAuth:Anonymous Activity] : Authentication success
[16:27:54] [API:admin Activity]   : Updating the application.
[16:28:04] [API:admin Activity]   : Updating the application.
[16:28:05] [steamcmdplugin:admin Warning] : 2021/10/29 16:28:04 socat[160339] E unknown device/address "!111 +force_install_dir 105600 +app_update 105600 validate +quit"

looks like it's getting some type of error when it tries to run it

cmdr_scotty posted this 29 October 2021

Further on this, if i'm reading it right, it looks like AMP is passing the command to SteamCMD incorrectly.

Looks like it's setting the ForceInstallDir and App_Update parameters to be 105600, in which it's then throwing an error that 105600 isn't a valid directory to install to.

Poking around but I can't seem to find which file or script it uses to pass the parameters to it as I want to compare this against Valheim or Satisfactory which created without issue, and update properly as it feels like this might be an issue with how performing the initial setup for Terraria

Mike posted this 29 October 2021

Everything AMP is doing for updating is correct and by design. I've just validated what it's doing and created a Terraria system on Ubuntu.

Does your steam password contain a double quote? Sometimes that can cause headaches.

Terraria has its own module rather than using generic so there's nothing user editable.

cmdr_scotty posted this 29 October 2021

So I changed my password (no double quotes, but changed it anyway to make sure that wasn't the issue), and even disabled steam guard.

Deleted the instance and created a new instance for Terraria, went to manage, and hit 'update' It asks for my steam creds, which it will accept, and i see it start downloading the SteamCMD package. Once that finishes it just says 'Unable to run'

(for some reason it's not letting me post a reply with images so had to edit the main post with them)

Mike posted this 29 October 2021

Show me the exact message, don't paraphrase.

cmdr_scotty posted this 29 October 2021

Its in the first screen shot that i added to the main post (since it won't post if i try to embed images in a reply)

Application State: Unable to run

that's all it gives back as a loading bar in the top right of the page, as well as in the notification pop-up it gives:

Updating Terraria

and just loops endlessly

Mike posted this 31 October 2021

In the file manager are the Terraria files actually there?

cmdr_scotty posted this 01 November 2021

Unfortunately no, the only items that are showing in FileManager:

LocalBackups (nothing in that folder)

looking at the actual file path in linux


reflects what File Manager shows in that only linux32,, and has been created.

As a thought, tried manually making the 105600 dir within the terraria folder but it still fails to create, leads me to believe that it's either failing to switch to the appropriate dir prior to running the steamcmd command, or something else is afoot

Mike posted this 01 November 2021

When you installed AMP, did you select the option to install the 32 bit libraries? You can check in /root/ampsummary.log

cmdr_scotty posted this 01 November 2021

it does appear that I did select that during install:

Installation Summary:

AMP System user:                To be created
Instance Manager:               To be installed
HTTPS setup:                    No
Install Java:                   Yes
Install 32-bit libraries:       Yes
Install Docker:                 No

Mike posted this 01 November 2021

Does your steam password contain any special characters? Try changing it to purely alphanumeric. There may be something in there that's not on the default escaped characters list.

cmdr_scotty posted this 01 November 2021

so first, whoa

second, what the actual heck?

third, I'm quite bamboozled.

it was the password which is strange that it would have an issue with those char (i can PM you what it was if that helps with improvements)

but changed it to an alphanumeric pass, and it worked :)

that's super weird, lol.

But glad that it's actually downloading and launching the server correctly :)

Mike posted this 01 November 2021

If you could post just what the non alphanumeric characters were by themselves so I can compare it to the list of characters AMP needs to escape that'd be helpful.

cmdr_scotty posted this 02 November 2021

so all the prior password had that wasn't alphanumeric was !!! at the end of the password

everything else was letter or number