Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Unable to create backups for Minecraft

  • Last Post 10 July 2021
  • Topic Is Solved
bcwolfen posted this 09 January 2021

First time using AMP. I installed on Debian Buster. Fresh install of Debian, and AMP. Managed to get our Minecraft server running perfectly. The only thing I am unable to get working is the AMP backups. I can backup AMP itself, but not the Minecraft server.

Scheduled backups do not run. Manual backup states: "Unable to start backup" This occurs if the MC server is running or is stopped.

Any ideas what I am missing?

Thank you

Order By: Standard | Newest | Votes
bcwolfen posted this 18 January 2021

Anyone have any thoughts on this? Still haven't been able to create backs for our MC server using AMP.

bcwolfen posted this 18 January 2021

So did some more digging with debugging enabled and it looks like a permission issue. "**" is the superadmin user and should have permission for all the plugins, unless its a file/folder permission in Linux. Any ideas what I should check?

[11:50:50] [RemoteAMPAuth:Anonymous Activity] : Authentication attempt for user **** from
[11:50:50] [RemoteAMPAuth:Anonymous Debug] : Logging in via remote auth server http://localhost:8080/...
[11:50:51] [RemoteAMPAuth:Anonymous Activity] : Authentication success
[11:50:55] [FileBackup:Amper Activity] : Creating Backup: 
[11:50:55] [FileBackup:Amper Debug] : Building file list...
[11:50:55] [APIService:Amper Warning] : Returned exception from API call LocalFileBackupPlugin/TakeBackup
[11:50:55] [Core:Amper Error]     : IOException
[11:50:55] [Core:Amper Error]     : [0] (IOException) : Permission denied
[11:51:00] [Core Debug]           : Exception posting server metrics.
[11:51:00] [Core Error]           : SocketException
[11:51:00] [Core Error]           : [0] (SocketException) : Connection refused
[11:51:00] [Core Error]           :   at Net.Sockets.Socket.Send (Byte[] buffer, Int32 offset, Int32 size, Net.Sockets.SocketFlags socketFlags) 
  at Net.Sockets.UdpClient.Send (Byte[] dgram, Int32 bytes) 
  at ModuleShared.MetricsInfoPublisher.ScheduleHandler (Object sender, EventArgs e)


Mike posted this 18 January 2021

Run ampinstmgr fixperms as root.

  • Liked by
  • pepperjack
bcwolfen posted this 18 January 2021

Run ampinstmgr fixperms as root.

Thanks Mike, That seems to have fixed it!

pepperjack posted this 10 July 2021

Thanks this also fixed my issue!!