Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Unable to Download FTB Beyond using McMyAdmin on AMP

  • Last Post 09 November 2017
82280zx posted this 08 November 2017

  1. Windows 10 Pro 64 Bit - Build 15063.674
  2. AMP Version "TN/SR3" built 02/11/2017 13:53
  3. McMyAdmin Module
  4. Unable to Download FTB Beyond MC 1.10.2, Files Download but it get stuck "Extracting Files..."

Steps to reproduce:

  • Log into McMyAdmin Instance server
  • Select Configuration
  • Select Server Settings
  • Changed Memory Limit to 3072
  • Selected Server Type "Feed The Beast"
  • Selected FTB Modpack "FTB Beyond (MC 1.10.2)"
  • Selected Release Stream "Stable"
  • Then clicked Install / Update

I've tried to fix the problem by stopping the Instance and clearing out the Minecraft folder in the Datastore then repeated the steps above to have the same problem happen.

[21:08:34] [System:Lance Activity] : Updating the application. [21:08:34] [System:Lance Debug]   : Downloading from, saving to ./Minecraft/ [21:08:34] [System:Lance Debug]   : Downloading, saving to C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\tmp1156.tmp [21:08:52] [System:Lance Debug]   : Moving C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp\tmp1156.tmp to ./Minecraft/ [21:08:52] [Minecraft:Lance Error] : File doesn't exist after download is complete. Cannot update.

Order By: Standard | Newest | Votes
Mike posted this 08 November 2017

Looks like the URL is 404ing, but there's a bug that's stopping AMP from reporting the error and dismissing the notification.

82280zx posted this 08 November 2017

When I click the link I listed in the log it I am able to download the file and I'm able to extract it via windows. I see the in the Datastore Minecraft Folder, but when I try to double click it it I receive Access to the Compressed (zipped) Folder 'C:\Users\mrpib\AppData\Local\CubeCoders\Amp\Instances\1-McMyAdmin-Adults\Minecraft\' is denied.

82280zx posted this 08 November 2017

Just an update as well, I just tried a different feed the beast pack, Horizons III and I get the same problem, file downloads but gets stuck extracting.

Mike posted this 08 November 2017

Is the instance running as a service? Check that the NETWORK SERVICE user has read/write access to that directory.

82280zx posted this 08 November 2017

The Minecraft Folder shows NETWORK SERVICE and has all rights except for Special permissions. It is also running as a service.

82280zx posted this 08 November 2017

I see it save the file and move the file to the right folder (minecraft in the correct instance folder) but then it says it doesn't exist? I checked the properties of the zip file it moved and it doesn't have NETWORK SERVICE rights? Update: When I run the instance as a Service the zip file has NETWORK SERVICE, when I run it without setting it up as a service it doesn't tag the zip file with NETWORK SERVICE.

82280zx posted this 08 November 2017

I noticed I'm behind on my windows updates, I will try getting everything current and retry things again.

82280zx posted this 08 November 2017

Did all my updates and tried reinstalling AMP / McMyAdmin still no luck, will try it on my other computer to see if it makes a difference. Update: I still am having the same issue on another install / different computer.

Mike posted this 09 November 2017

This bug has been resolved, you can either grab the next nightly or wait for the next mainline release.