Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Unable to select "Specific Version" on Spigot for Minecraft Instance - Bug?

  • Last Post 24 June 2020
  • Topic Is Solved
Dark posted this 16 June 2020


I'm fairly new to AMP and Minecraft servers in general, but very familiar with Linux, Unix, VMs, CLI stuff, and IT in general. Currently trying to get a 1.15.2 Minecraft instance set up with Spigot.

I have installed AMP using the "wget" command on an Ubuntu 20.04 LTS instance.

Here are my current settings:

Server Type: "Spigot"
Release Stream: "Specific Version"
Spigot/CraftBukkit Version: [empty]
Server JAR: "[Autoselect]"

Under "Spigot Version", there are no items. If I switch back to "Official", I can see the different official Minecraft versions.

In the console, it says:

Exception in thread "main" joptsimple.OptionMissingRequiredArgumentException: Option rev requires an argument

So clearly it's failing to provide the version in the command to build it like it should: java -jar BuildTools.jar --rev 1.15.2 because the Spigot versions aren't being populated for some reason. However, I don't see any way to override this manually.

Switching from "Specific Version" to "Stable" seems to work as expected, since I believe it's providing --rev latest correctly. I can see it build, then end off with the following:

Success! Everything completed successfully. Copying final .jar files now.
Copying spigot-1.15.2-R0.1-SNAPSHOT.jar to /home/amp/.ampdata/instances/Minecraft02/Minecraft/spigotbuild/./spigot-1.15.2.jar
- Saved as ./spigot-1.15.2.jar

I would prefer to be able to manage specific versions just in-case we need to roll the server back to a previous version, keep it on a specific version, use an older version, etc. I also am aware I could build the server outside the VM instance and then pass it in, but two things:

1) I would prefer to have it easily configurable from the UI as it should be

2) I would prefer to not have to use the FTP of AMP, which seems to be limited to 80 KB/s for some reason. This would be a nightmare for uploading a whole world and JAR file. I also am not sure if I can access the VM manually in the actual server's filesystem to transfer files that way.

So I'm fine with doing stable for now, but am I missing something or this is a legitmate bug? Let me know if you need any other information.

Order By: Standard | Newest | Votes
Mike posted this 16 June 2020

Restart the instance, it probably failed to download the version list. Also if you use thr actual FTP using a client like Filezilla it's much faster.

Dark posted this 19 June 2020

Restarting the instance didn't work. Also, what do I connect to for FTP? Connecting normally just connects me to the actual server that is running AMP and not the file system that amp houses it's files in.

Edit: Off topic, but I do want to say: I tried MineOS and Pterodactyl and they were incredibly inferior to AMP. On both I wasn't even able to get a server close to started, but AMP was super easy to use.

Just want to say I appreciate that fact.

bonsaieas posted this 19 June 2020

I've found that transferring files from another machine (I do it from my laptop), and to the base File Manager (not the one in the Local Instance), gives much more reasonable speeds. No idea why.

I am having the same issue, and wanted to add that I am able to see versions for Official, Paper, Forge, and others. I'm able to download the versions manually from the Spigot site.

Mike, how would we go about manually installing a specific Spigot version to AMP?

  • Liked by
  • Dark
maggi373 posted this 20 June 2020

Has this been fixed or? since im also cant get spigot versions, and stable gets me 1.15, im not running that version

bonsaieas posted this 21 June 2020

No, we are still waiting on a resolution.

It may be possible to build the server outside of Amp, and file transfer into the instance. I will test this when 1.16 is released.

Mike posted this 21 June 2020

Has anyone actually checked their logs when AMP starts up to see why it's failing? Make sure debug mode is enabled.

Mike posted this 23 June 2020

So looks like the Spigot lot are returning a HTTP 403 (Access Denied) when AMP requests the version data as opposed to a browser. I've changed the user agent to get around this.

  • Liked by
  • Dark
Dark posted this 24 June 2020

Thanks Mike! Looks like I can select the specific version now, though, it appears that it's failing to provide the "rev" argument:

Exception in thread "main" joptsimple.OptionMissingRequiredArgumentException: Option rev requires an argument

I believe the command looks like this:

java -jar BuildTools.jar --rev 1.15.2

This is a similar issue we had on MineOS. I personally will still be using latest, but I think once this is fixed we will be peachy.

Edit: Actually, looks like it is working now. I don't think it applies the rev value by default until you manually select it and the loading icon disappears. Just tried with 1.14.4 and it seems to have created the JAR properly.

Thanks for all your help! Looking forward to continue using amp!